Secondary Monitor Quality

I have an (WPF) application that plays a video and a scrolling text below on an LCD TV.

When I set the LCD TV as the primary monitor and monitor as secondary, it works perfectly. But when I set the LCD TV as the secondary monitory and the monitor as primary, the video lags and the scrolling text is not smooth.

Is there a way to "allot" more "video" resources for the secondary monitor?

I am using nvidia GT220 on windows 7 (but I also tested on win xp with the same problem)
LVL 22
ThomasianAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob KnightConsultantCommented:
Hi,

This could be a video overlay or similar problem when sending that video to the secondary monitor.

Have you set the refresh rate to be the same on both montiors?

Regards,


RobMobility.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ThomasianAuthor Commented:
Wow! Changing the refresh rate significantly improves it! I have been working at this for hours without any improvement.

Thanks!


Can you elaborate more about the video overlay?
0
Rob KnightConsultantCommented:
Hi,

I think WPF uses directdraw or directplay - you might be able to tweak that but I have seen issues where an application which uses DirectDraw, for example, plays less well on a second display.

You might want to check that Video Acceleration is being enabled as well - most if not all modern video cards accelerate video to offload the work from the CPU.

You could try disabling Aero as well - that consumes hardware resources especially on less powerful video cards such as integrated/lower end.

You can try tweaking refresh rates a bit (59 Hz, 60 Hz etc) but it sounds as if you have made some progress.

Regards,


RobMobility.
0
ThomasianAuthor Commented:
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.