Suse Linux box not resolving DNS

I have a suse linux box that doesn't seem to want to resolve DNS, either from the console (ping, etc) or from the services running on it.

BIND is running locally on the box and /etc/resolv.conf is set to 127.0.0.1 for the DNS server. BIND is setup with proper forwarders and other boxes that use this server for DNS resolve just fine.  I can also run nslookup and resolve hostnames just fine, it just doesn't work for other things.

/etc/nsswitch.conf has:
services: files dns
hosts: files dns

Appreciate any ideas. Thanks!
LVL 5
valheru_mAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pilson66Commented:
Your DNS service is listening on localhost ?
see "netstat -nltup"
you must see like:
 
udp        0      0 127.0.0.1:53            0.0.0.0:*                           923/named

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pilson66Commented:
Also, you need the next code in options.conf
Example:
 
/*
         * For localhost configuration, uncomment the listen-on directive below.
        */
              listen-on { 127.0.0.1; };

Open in new window

0
valheru_mAuthor Commented:
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      -    
udp        0      0 127.0.0.1:53            0.0.0.0:*                           -    

Both of those appear in the output of your command.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

pilson66Commented:
in options.conf
 
allow-query { localhost; localnets; };

Open in new window

0
pilson66Commented:
In my config:

 
options {
        version "unknown";
        directory "/zone";
        pid-file "";
        dump-file "/var/run/named_dump.db";
        statistics-file "/var/run/named.stats";

              listen-on { 127.0.0.1; 10.0.0.92;};
              forwarders { 8.8.8.8; 213.160.128.3; 80.91.160.2; 83.218.227.100; };
              recursion no;
              allow-query { localhost; localnets; };
};

Open in new window

0
valheru_mAuthor Commented:
Bah, I need to get more sleep.  I just changed the /etc/resolv.conf to the local IP addy instead of 127.0.0.1 and it's working fine now.  I'll give ya the points since your suggestion put my train of thought on the right tracks.  

thanks for the help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.