Connecting 2 Cisco 2950 and 1 2960 switches

I have a single small business LAN, no Vlans or anything fancy.  My hardware includes two Cisco 2960 switches and one 2950 switch.  

What is the best way to connect these Cisco devices (which ports to which ports on which devices) and what settings should I make on those ports?

 
LVL 1
Tom FI.T. and Support Staff ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig BeckCommented:
The 2950 may or may not have a GBIC slot, but assuming it does, and that you use gigabit GBICs (1000Base-SX) in the 2950s and a gigabit SFPs in the 2960, you can use the following basic config on each switch (bearing in mind you have no VLANs)...


On the 2950s...

interface gi0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown



On the 2960...

interface range gi1/0/1 - 2
switchport mode trunk
no shutdown



This would enable you to use the 2960 as the 'hub' switch, and connect each 2950 to the gigabit SFPs on the 2960.

0
OLY8892Commented:
What is it you are trying to achieve with this network?  Need more info, what are you connecting to the switches, number of servers, hosts, etc.

You will need to connect the switches using crossover cables. Are you stacking the switches? Then you would use a giga stack cable.

Use one 2960 for the backbone and other for servers, the 2950 for the access layer.
0
Craig BeckCommented:
Fibre cables (as mentioned by using 1000Base-SX GBIC and SFP modules) are crossover cables, and are a standard switch-to-switch interface.
0
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tom FI.T. and Support Staff ManagerAuthor Commented:
I'm an idiot and totally botched the question... I apologize.  I have TWO 2960's and ONE 2950.  (I stated the opposite in the op)

There is no gbit on the 2950.

I have about 40 hosts, 4 servers.
0
Tom FI.T. and Support Staff ManagerAuthor Commented:
None are currently stacked, although if the configuration called for it I could stack the 2960's.  Is there much of a benefit to doing so - other than simplified management?
0
Craig BeckCommented:
On the 2950...

interface fa0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown



On the 2960s (assuming the 2960s are 24-port)...

interface range gi1/0/1      (on one of the 2960s only)
switchport mode trunk
no shutdown

interface gi1/0/25                
switchport mode trunk
no shutdown



Link the 2960s via fibre (port gi1/0/25 if 24 port), and link the 2950 to port fa1/0/1 on the 2960 you configured.
0
Craig BeckCommented:
You can only stack the 2960s if you buy the stack module.
It will increase bandwidth between the 2960s to 10Gbps.

If you did this you would probably only need the following...


On one 2960....

interface range gi1/0/1      (on one of the 2960s only)
switchport mode trunk
no shutdown


On the 2950...

interface fa0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OLY8892Commented:
For the servers and hosts

interface fa(port #)
switchport mode access
ip add (ip add...subnet mask)
no shutdown

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.