remove initial login prompt in exhange 2007 owa

I have
LVL 2
WinstinkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

transgroupCommented:
you have.......?
0
WinstinkAuthor Commented:
wow. Ok, sorry about that.  Not sure what happened.  ANYWAY:

We recently installed exchange 2007.  When we go to the OWA page, we are prompted for our UN/PW by a pop up window, and then when we are authenticated, we get to the actual login page.  How do I remove the initial login page so when people get to the OWA page they just get the login page?
0
Viral RathodConsultantCommented:
Please make sure Exchange 2007 Latest Service Pack 2/3 is installed on the server

Please refer this "demazter" article for more information

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html

If that doesn't work check the authentication methods as per "demazter" blog here: http://demazter.wordpress.com/2010/11/09/outlook-prompting-for-username-and-password-when-using-exchange-2010/ 
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

MegaNuk3Commented:
Yep, as viralrathod has said. Ensure SP3 for Exchange 2007 is installed.

Then check the OWA virtual directory in IIS and make sure the AUth method is 'Basic' only.
0
WinstinkAuthor Commented:
Will upgrade tonight off hours, then check it out.  Thank you.
0
MegaNuk3Commented:
No problem. After SP3 is installed check IIS and make sure the right cert is assigned - I have seen SP3 re-assign the self signed cert to IIS.
0
WinstinkAuthor Commented:
OK, SP3 installed.  basic authentication is the only one checked in OWA,  The articles you provided talk more about Outlook rather than OWA, but I checked the Vritual Directories anyway and checked the kernel authentication.  It is still doing a double authentication. See attached screen shots.  OWA1 is what I get when I go to the OWA address.  Once I authenticate, it brings me to OWA2, where I have to authenticate again.  I'm trying to get ride of the first prompt (owa1) First Login prompt when goint to OWA First Login prompt when goint to OWA I want it to go directly to this page instead
0
Llacy80Commented:
What do you have set for you authentication on the default web site? Which is enabled?
0
WinstinkAuthor Commented:
only anonymous is enabled.  
0
Llacy80Commented:
What type of certificate are you using? Self signed or third party?

It should really be a third party and make sure to purchase a SAN cert..On the article listed above follow dematzers guide and make sure that you have all the names in the cert (autodiscover, owa, remote, etc).
0
WinstinkAuthor Commented:
i guess self signed.  Is a certificate really causing authentication issues?
0
Llacy80Commented:
I have seen it before..It's really just a hassle to use a self signed cert in my opinion especially when you start adding active sync in to the mix
0
Llacy80Commented:
0
WinstinkAuthor Commented:
I just installed this server, so it's not a matter of it expiring.  Activesync works fine for now.  
0
MegaNuk3Commented:
Check the OWA virtual directory and make sure authentication is basic only.

0
WinstinkAuthor Commented:
yes I did check that and it is the only authentication checked.
0
MegaNuk3Commented:
Why did you say that "anonymous" was there earlier?
Try do an IISReset and test again.

Also in IIS on the OWA directory check the 'HTTP Redirects' and ensure it is not redirecting anywhere.

You should be able to hit https://<CASServerName>/owa from internal without 2 credentials prompts, can you?
0
WinstinkAuthor Commented:
anonymous is enabled at the "Default web site" level.

I did try restarting iis.  How do I check http redirects in server 2008.  
I CAN hit https://server/owa without two credential prompts, but not /exchange


0
MegaNuk3Commented:
You should be using /owa as it is Exchange 2007
0
WinstinkAuthor Commented:
Ok, so follow up question.  Is there a way to make /exchange redirect to /owa (so I don't have to tell my users to learn a new OWA address)?

thanks.
0
MegaNuk3Commented:
/exchange redirects to /OWA by default, check HTT Redirects on it in the middle pane and you will see what I mean. Also check your auth methods for /exchange, I'll be able to tell you what the defaults are in a bit
0
MegaNuk3Commented:
Sounds like you need to set forms based authentication on /exchange and /exchweb as per this article:
http://technet.microsoft.com/en-us/library/aa998867(v=exchg.80).aspx

And that should get rid of the 2 prompts
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WinstinkAuthor Commented:
it was FBA on /exchange.  Thank you.
0
MegaNuk3Commented:
No problem, I learnt something new there too.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.