VOIP with Dell Switches

I have three Dell switches in two different buildings.  A powerconnect 3424, 2848, 5224.  The 5224 and 2848 are connected via a fiber link.  The 3424 is connected via a gigabit port on the 5224.  They are upstairs from each other.  There is only one other switch on the network, a small 5 port netgear gigabit switch (that I have taken out to troubleshoot with no difference).  Here is the problem.  We just switched to a VOIP system.  We have Broadview Networks and Mitel phones.  Maybe 35 phones.  We have 50mb/10mb bandwidth and that is fine.  The system works great when we call out to a phone number or someone calls in.  When we dial an internal extension, sometimes the audio is only one way and one person cannot hear.  If we hangup and keep trying, after 4 times or so, it will work.  I was told this is likely a switch issue.  All my switches have IP's so I can manage them, but nothing has been setup.  They are default configs.  We also have a sonicwall pro 3060 between the cable modem and our network.  Can someone help with this?  I heard perhaps creating VLANS, but I do not know how.  I need someone to help!  
zzASLANzzAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Defienitely setting QoS on the switches would help (I believe those switches can prioritize traffic). Also make sure that you IP addressing is set so that the traffic from the phones isn't trying to go through your external switch/router.

The other option is, as you said, to create VLANs. This is probably the best solution, provided all of your network equipment supports it. Its a little tricky depending on your setup. We use mitel phones here. The phone traffic is tagged and the PCs connect through the phones and send on a different VLAN, but untagged. Then the switches are set up to keep the data and phone traffic away from each other.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zzASLANzzAuthor Commented:
Just got off the phone with a tech who thought that my firewall was causing the issue.  He said the traffic is hitting the firewall.  Said something about RTP, but wanted to call me back.  In the meantime, I found a RTP and created an access rule to allow that and it seems to work now??  Does that make sense to anyone?  This is a bit unfamiliar to me.  
0
zzASLANzzAuthor Commented:
Nevermind.  It is still happening.  But the guys was pretty certain it was an issue with my firewall.  There system is outside our firewall.  Any other ports I could open on the sonicwall?
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Ron MalmsteadInformation Services ManagerCommented:
It is preferrable to segregate your data and voip traffic, however, if this were the cause of the problem then you would experience it on outbound calls as well.

One way audio is usually caused by NAT issues in routing.   If you are routing between networks via the firewall that could be the issue.

Why would your phones be bouncing thier traffic off the firewall ?...are they not all on the same internal network ?
0
zzASLANzzAuthor Commented:
they are all on the same network, but the solution is a hosted one.  so the phone system is outside of our network.  i also just selected enable consistent NAT, which I read may help and so far it seems to work.  still testing....
0
zzASLANzzAuthor Commented:
still happening!
0
Ron MalmsteadInformation Services ManagerCommented:
Seems your phones are not configured to do direct RTP setup internally.

You may ask your hosted provider if they can change this on their end, or if you can make a change to the settings on the phone.

What this would do, is take the hosted PBX out of the conversation when two phones on the same network are calling each other.  Thus, your network traffic will not have to go out to a remote pbx, then back in to conduct a conversation with the end peer on the same network.

This is definitely do to NAT setup and/or  pbx/Phone configuration.  You should get the provider involved again.
0
davdjevansCommented:
Looking at your initial post, I wouldn't expect the issue to lie with the switches because you mentioned that external calls works fine.
I have a question though: Are you using a Mitel controller (MCD or 3300) to control the phones and if so is it located on your premises?
0
zzASLANzzAuthor Commented:
I am not sure the controller, I can ask Broadview.  It is not on our premises though.  The phone are Mitel.  
0
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Didn't realize your phone system is hosted externally. So the part where I talked about changing your phone routing won't apply. Either way setting up QoS will help. Particularly on your firewall.
0
davdjevansCommented:
There is a local streaming option that can be enabled on the Mitel Border Gateway (MBG) that may be of interest.
The concept behind it is that if phones are connected to the controller over the Internet, then MBG is placed in the DMZ and acts as a firewall and NAT server. When two phones that are located on the same network want to talk to each other, without local streaming they need to communicate through the MBG server (because MBG would treat them as two phones connected randomly to the Internet).
If the local streaming is enabled they can communicate directly with each other. Meaning that your RTP (voice Packets) don't need to go to the firewall because they are handled inside the network (phone to phone).

So... we could do with finding out how the provider is hosting the solution. Whether they use MBG or not? and if so could local streaming be used?
0
zzASLANzzAuthor Commented:
Working with the Vendor.  They are also having trouble.  Thanks for all the input!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.