Sharepoint 2010 giving errors after renaming the Administrator account.

We have a Sharepoint 2010 server which has been running just fine until we changed our domain administrator account name from Administrator to another name.  Now I am able to log into sharepoint and access and create/modify tasks, but search does not work and I am unable to use the Central Administration page to change the sharepoint account settings.

If I use Sharepoint Central Administration and go to Security > Managed Accounts, I see our new administrator account listed (it is the only thing listed) but if I click "Edit" and try to save the settings or even create a new managed account, I receive this error:
"The specified user or domain group was not found."

I am also receiving this error when I attempt to search within sharepoint:
"Internal server error exception:

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: e1623651-8a30-48f6-899e-494c7e10a860"

If I try to access the Search Application through Central Administration, I receive the
"The specified user or domain group was not found" error message.

Can I use the SPConfig tool to make sure everything is using the new account name properly?
LVL 2
OAC TechnologyProfessional NerdsAsked:
Who is Participating?
 
Justin SmithSr. System EngineerCommented:
0
 
Justin SmithSr. System EngineerCommented:
Did you make the Admin account your farm admin account?  Meaning, is the admin account running the SharePoint Timer service and the Central Admin app pool?
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
Yes, the sharepoint timer service and central admin app pool is using the new admin name
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Justin SmithSr. System EngineerCommented:
Ok.  Did you just change the display name, or the actuall account name?
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
The actual account name of the domain administrator account was changed
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
Any suggestions?
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
Thanks, that got me a little further.  Search is still not working, but I'm no longer getting "The specified user or domain group was not found" error.  When I run the configuration wizard, it crashes at the Search Services with this error in the log file:

Exception: System.InvalidCastException: Unable to cast COM object of type 'Microsoft.Office.Server.Search.Administration.MSSITLB.CGatheringManagerClass' to interface type 'Microsoft.Office.Server.Search.Administration.MSSITLB.IGatherManagerAdmin3'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{0FF1CE14-013A-0000-0000-000000000000}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY)).
   at Microsoft.Office.Server.Search.Administration.Gatherer.get_AdminObject()
   at Microsoft.Office.Server.Search.Administration.Gatherer.ProvisionGlobalProperties()
   at Microsoft.Office.Server.Search.Administration.Gatherer.Provision()
   at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Provision()
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServices(Boolean provisionTheServicesToo)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()
0
 
Justin SmithSr. System EngineerCommented:
I'm guessing you set this admin account as your Search Service and App Pool account as well?

If you go into Central Admin - Security - Service Accounts, can you change your account for Windows Service SharePoint Server Search, and also (if applicable) Service Application Pool - whatver your search is.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.