links in windows mail won't open with IE 9.0.

My ISP sends me a spam digest once a week.
Since I have been using IE 9.0 (version 9.0.8080.16413) the link in this e-mail does not open in IE.
I called tech support for my ISP and they said it is a compatibility issue between IE 9.0 and Windows Mail and is a Microsoft fix, not them.
Accessing the spam digest using Firefox does work but this is by entering a specific web link in the address bar and not using the direct links in the e-mail.
This is the "only" links, in Windows Mail that does this.
Are there any settings that would affect this?
Did I download a beta version of IE 9.0?
My ISP tech support said they had no way to fix the problem, it is on Microsoft's end. IE 9.0 is failing to correctly read the weblinks in this "once a week" e-mail with a link to my spam digest. Like I said it is the only e-mail links that do not work properly.
Any ideas?
Looking to fix the problem not switch browsers.
Maybe my version of 9.0 is the issue and not IE 9.0 in general.
Thanks.
LVL 25
nickg5Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zvitamConsultantCommented:
Since it's a spam digest I assume that the links inside it are disable on purpose, since some of these links lead to an unwanted sites.

so, if there is a URL you want to use - you will have to copy it into the address bar windows rather than just clicking it.
nickg5Author Commented:
Before IE 9.0, I only had to click on the link and I was already logged in to the spam digest, I was able to keep or delete, and then log out.

So, it is related to IE 9.0 according to my ISP tech support.
I've never had to copy a link before, and actually the link is hidden in the word
"view" and can not be copied.
But, with IE 7.0 and 8.0, all I had to do was click on "view" and the spam digest opened right up.

It's only with this specific e-mail and specific link.
All other links in all other e-mails open up in IE 9.0, normally.

Marc ZCommented:
Can you please copy/paste one of the links here? Maybe u just need to set proper file associations.
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

nickg5Author Commented:
https://spam.comporium.net/console/

the above opens up to a sign-in window with Firefox.
the above does not open up with IE 9.0 (my screen is blank)

my ISP sends me an e-mail, weekly that contains a link to the spam digest. The link is within the word "view" in "view quarantined messages."
I can not post the link because if you are successful in opening it, it will have "you" logged in to my e-mail box.

It all worked fine until I moved to IE 9.0.

As I said, it is the only link in any e-mails, to any websites, that won't open in IE 9.0. All others open fine to Ebay, EE, etc.
nickg5Author Commented:
zvitam:
Since it's a spam digest I assume that the links inside it are disable on purpose, since some of these links lead to an unwanted sites.
...............the link has always opened up the "personal dashboard" and had me logged in, so I could view quarantined messages and delete them as desired.

so, if there is a URL you want to use - you will have to copy it into the address bar windows rather than just clicking it.
................never had to do this with IE 7 or 8.

mtx1of4:
Can you please copy/paste one of the links here? Maybe u just need to set proper file associations.
.................the only link is within the word "view." and always has been. I can not post the link because if you get it opened you have access to my mail box.

----------------
this weeks e-mail has arrived and there are 20 messages in the spam digest. I clicked on "view" and IE 9.0 tries to open it but the page is totally empty, blank.

--------------------
Try these 3 steps:
Here is your Personal Dashboard. To access, click on the Personal Dashboard link below.
(this link is the word "view")
For answers to frequently asked questions, please go to http://www.comporium.com/spam.

1. click on that link.

2. Then in the list of questions click on:
How do I check for quarantined messages sent to my comporium.net account?

3. Then click on:
The first is to login to the Personal Dashboard by navigating to to http://spam.comporium.net

With Firefox, the spam.comporium.net gets me to the login page.
IE 9.0 is a blank page.

What are you getting when you do the 3 steps above?

Do you get this:
https://spam.comporium.net/console/
when you use IE 9.0?
(I don't)
Marc ZCommented:
Actually i haven't installed ie9 yet.  
perhaps you need to lower your security options.
http://windows.microsoft.com/en-US/windows7/How-to-use-Tracking-Protection-and-ActiveX-Filtering
turn on compatibility view for spam.comporium
http://windows.microsoft.com/en-US/windows7/How-to-use-Compatibility-View-in-Internet-Explorer-9
here's some more troubleshooting and updating tips.
http://windows.microsoft.com/en-US/internet-explorer/help/ie-9

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nickg5Author Commented:
I'll look into that

and

also wait and see if someone with IE 9.0 can follow those links I gave, and see if the console page loads for them.

It works fine with Firefox, but copy-pasting links, and then having to enter my user name and password is alot of steps, when......all I had to do before, to not only get to the spam box, but it already had me logged in, was click on "view"

(and I use Firefox and IE, so not looking for new browsers)

Marc ZCommented:
maybe firefox just needs to allow cookies, or saved password for that login.  Do you know how to allow those things in Firefox?
Tools->Options->Security for saved passwords
and tools->Options->Privacy->Use Custom Settings for history and select appropriate Cookie settings.  Probably have to allow third party, if i had to guess.
nickg5Author Commented:
Firefox and the links work fine.

they do not work with IE 9.0, the actual link to the console, and the "view" link in the weekly e-mails. They did with IE 7-8
Marc ZCommented:
I understand nick,
but you said, "It works fine with Firefox, but copy-pasting links, and then having to enter my user name and password is alot of steps,"
so  i thought i'd give you some more options to look at for firefox to make it easier for you.

IE 9 seems to have buttoned up some of its security holes. nothing wrong with that, imho.
Have you tried reducing the Security settings in IE9, yet, or added comporium.net to your Trusted Sites, if you trust them?
nickg5Author Commented:
Have you tried reducing the Security settings in IE9, yet, or added comporium.net to your Trusted Sites, if you trust them?

.........I'll try that....
nickg5Author Commented:
I went to IE 9.0 tools > internet options and added the copied shortcut from the word "view." Then when clicking "add," it always changes the precise link to just comporium.com or spam.comporium.

So, I let it add what it wanted to.
Then I tried again by clicking on the link to the website, then to the FAQ, and then to the link provided. These series of steps as listed above, do get me into the spam digest, but I have to say "yes" to Windows, since it says I am trying to open a trusted site, do I really want to do this.
Of course the answer is yes.
I have to do this twice.

Then by adding the link to the console, I get in and am logged in to. But, still I have to approve the site two times.

It's a trusted site.
Is there a setting that I can use to make it stop prompting me on trusted sites?

This bug or problem, with IE 9.0 is not something Microsoft will fix because it is, as far as I know, only my ISP, or only the ISP's, that use the personal dashboard.
Tech support told me that they have had the same complaint from others and it is clearly Microsoft's issue or a Windows or IE 9.0 setting.

I can get there by saying yes to the site two times. Any way around this?

I like 9.0 but might go back to 8.0 until 10.0 comes out and the link works.
No sense having to take extra steps to do something. It is supposed to make things work better, not worse.
Marc ZCommented:
nickg5Author Commented:
since it was prompting me twice, I went back to trusted sites and removed one.
I had entered the ISP website and then the link that their tech support told me to get to the spam. I removed the spam.comporium link.

I added the site on the cookie list, and there were no other sites listed, so now there is one.

I am able to get to the spam digest directly from the word "view" in the e-mail.
I think the trusted site did it. The compatibility view was part of it too, I think.
I am not longer getting a message that I am needing to say "yes" to the trusted site. Clicking "view" now gets me there as previous. There is a 2-3 second delay as if Windows is "doing" something before it opens it up. But, it is getting there.

Closing the question now.
nickg5Author Commented:
thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.