Partition on Drive disappeared

I have an Acer Aspire 6920G with Windows 7 Ultimate (32 bit.) I was updating video drivers and after one of the reboots one of the partitions disappeared. I have one hard drive on it with two partitions C and E and partition E disappeared. If i go to disk management i can still see the partition but it doesn't have a letter drive and when i right click on it it only gives me a "Help" menu instead of showing the options to formatt, change letter drive, etc.

I used a linux cd to see if icould still access the files and i can do it under Linux but not under Windows. I do not understand why did it disappear. Is there i way to get my letter drive back? I already did a system restore to yesterday and that did not work.

Thank you in advance.
Nancy VillaDirector of ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zvitamConsultantCommented:
I do not have clue why it happend but I would certianly try doing system restore to the point before the video drivers installed. This will probably bring (I hope) the lost partiton back.
0
Nancy VillaDirector of ITAuthor Commented:
0
Randy DownsOWNERCommented:
Try Disk Management (Right click My Computer/Manage - under storage)& see if you can change letter drive on your missing partition. Perhaps the partitiion is marked inactive.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Randy DownsOWNERCommented:
You might also try rescan disks under the actions panel on the right (more acations)
0
Randy DownsOWNERCommented:
0
Nancy VillaDirector of ITAuthor Commented:
No, it doesn't give me that option the only option that i get when i right click on the partition is "help"....I did a system restore back to Friday and that did not work either.
0
AustinComputerLabsCommented:
From the following article: http://answers.microsoft.com/en-us/windows/forum/windows_7-system/hard-drive-partition-has-disappeared/1e062634-1a78-4097-b833-6832819a45d9

1. Go to start and type cmd.
2. Right-Click on Cmd and select “Run as Administrator”.
 diskpart
3. At the DISKPART prompt, type:

 list volume

Make note of the number of the simple volume whose drive letter you want to assign, change, or remove.
4. At the DISKPART prompt, type:

 select volume n

Select the volume, where n is the volume's number, whose drive letter you want to assign, change, or remove.

5. At the DISKPART prompt, type one of the following:

assign letter=L

Where L is the drive letter you want to assign or change.

See if this helps in restoring the drive in Explorer
0
noxchoGlobal Support CoordinatorCommented:
Actually the partition id of your partition has changed and now it is 27 which means that it is OEM. In you screen capture you can see that this partition shows no file system and it means that partition is protected.
You need to change the ID first. Download trial from here: http://www.paragon-software.com/home/brh/
Install it and run. Change the view to Full Scale Launcher and there in disks layout right click on this partition and select Change Partition ID. Which ID is set there right now?
Also, are you able to assign drive letter to this partition via Backup&Recovery 10 home?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nancy VillaDirector of ITAuthor Commented:
I am trying to install Backup and Recoery progam but of course I get error 1327. Invalid Drive E:\
0
Nancy VillaDirector of ITAuthor Commented:
AustinComputerLabs I tried the DISKPART but ti doesn't list the drive I need. It only lists dvd drive, the c drive and another drive with 13gb on it. The one I need used to be the E drive and it should have about 112GB on it
0
noxchoGlobal Support CoordinatorCommented:
Do you have a USB flash drive? If yes connect it to your PC and in Windows Disk Management assign to it E: drive letter. Then try to install Backup&Recovery 10 trial.
There are references to non existing E: drive in your registry thus you get this error.
0
Nancy VillaDirector of ITAuthor Commented:
Putting a flash drive worked and this is the id I have right now: "Current system ID is 0x12 Compaq. Changing system ID might prevent some operating systems from working with the partition." I wasn't able to change the letter drive, it doesn't let me type on it.
0
Nancy VillaDirector of ITAuthor Commented:
Awesome!! I changed the ID to 07 like the C drive and it enabled the partition and then I was able to assign the E drive letter to it, thank you so much for your help!!!! It is working now :)
0
Nancy VillaDirector of ITAuthor Commented:
I used Paragon Backup and Recovery software as suggested by noxcho to enable the partition on my computer again.
0
noxchoGlobal Support CoordinatorCommented:
Thanks for feedback. Glad we could help.
Nox
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.