Adding clients Computers to WSUS 3.0

I have configured WSUS 3.0 SP2 on my 2003 R2 server.  I am able to open the console on the server.  I am still testing WSUS, and only downloaded and approved Win7 SP1.

I do not want to modify our global GPO yet, so I only locally modified the policy on my desktop.  I enabled Specify Intranet Microsoft update Service Location, and I set it to http://servername:8530 (i installed on post 8530).

After enabling this setting, and running wuauclt.exe /detectnow on my desktop, I still see 0 computers in the WSUS admin console.

Am i doing something wrong?!
SmallPrintAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SmallPrintAuthor Commented:
clientdiag results
0
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

SmallPrintAuthor Commented:
permission wise, everything looks fine.

Can this be related to WSUS being installed on a DC?  I have read nothing that states this can't be installed on a DC, but maybe you have heard different.
0
DonNetwork AdministratorCommented:
People install WSUS on DC's all the time, it's just not recommended/preferred.

Are you sure that you have "anonymous access" enabled where appropriate as described in the article ?
0
SmallPrintAuthor Commented:
Just double checked all IIS settings. They all have anonymous access enabled.

I want to confirm, I should be looking only at the WSUS Administration site, not the default, correct?
"WSUSAdmin" entry does not exist. checking for anonymous access
0
DonNetwork AdministratorCommented:
NO! You should be looking at the "Default" and it should also be started
0
SmallPrintAuthor Commented:
from my WindowsUpdate.log.
WARNING: SendRequest failed with hr = 800710dd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
WARNING: WinHttp: SendRequestUsingProxy failed for <http://fpsvrsko01:8530/selfupdate/wuident.cab>. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x800710dd
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x800710dd
WARNING: SendRequest failed with hr = 800710dd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
WARNING: WinHttp: SendRequestUsingProxy failed for <http://fpsvrsko01:8530/selfupdate/wuident.cab>. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x800710dd
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x800710dd
WARNING: SendRequest failed with hr = 800710dd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
WARNING: WinHttp: SendRequestUsingProxy failed for <http://fpsvrsko01:8530/selfupdate/wuident.cab>. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x800710dd
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x800710dd
WARNING: SendRequest failed with hr = 800710dd. Proxy List used: <(null)> Bypass List used : <(null)> Auth Schemes used : <>
WARNING: WinHttp: SendRequestUsingProxy failed for <http://fpsvrsko01:8530/selfupdate/wuident.cab>. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation MakeRequest failed. error 0x800710dd
WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x800710dd
WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x800710dd
WARNING: DownloadFileInternal failed for http://fpsvrsko01:8530/selfupdate/wuident.cab: error 0x800710dd
WARNING: SelfUpdate check failed to download package information, error = 0x800710DD
13c4	Setup	FATAL: SelfUpdate check failed, err = 0x800710DD

Open in new window

0
SmallPrintAuthor Commented:
i thought that it should be started yesterday, but when i try to start it i get error: The process cannot access the file because it is being used by another process.

just tried to start again..same error.
0
DonNetwork AdministratorCommented:
Even though you setup WSUS to use port 8530, WSUS still needs to use a selfupdate virtual directory under port 80 as you see under "Default" <<<so the permissions need to be correct there as well
0
DonNetwork AdministratorCommented:
Check this for your IIS issue

http://support.microsoft.com/kb/890015
0
SmallPrintAuthor Commented:
looking into this now...this should be fun. I'll report back once i get this thing going.
0
SmallPrintAuthor Commented:
i assume I should only be looking at port 80? Net state gave me the following about 80...


TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       1452
TCP    192.168.67.229:80      192.168.67.229:2674    TIME_WAIT       0



There is no listenonly port reg key listed.
Proto  Local Address          Foreign Address        State           PID
  TCP    0.0.0.0:53             0.0.0.0:0              LISTENING       2736
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       1452
  TCP    0.0.0.0:88             0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       748
  TCP    0.0.0.0:389            0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
  TCP    0.0.0.0:464            0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:593            0.0.0.0:0              LISTENING       748
  TCP    0.0.0.0:636            0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:705            0.0.0.0:0              LISTENING       3800
  TCP    0.0.0.0:1025           0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:1027           0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:1031           0.0.0.0:0              LISTENING       1348
  TCP    0.0.0.0:1041           0.0.0.0:0              LISTENING       2912
  TCP    0.0.0.0:1042           0.0.0.0:0              LISTENING       2912
  TCP    0.0.0.0:1049           0.0.0.0:0              LISTENING       2912
  TCP    0.0.0.0:1097           0.0.0.0:0              LISTENING       3560
  TCP    0.0.0.0:1154           0.0.0.0:0              LISTENING       2736
  TCP    0.0.0.0:1311           0.0.0.0:0              LISTENING       3896
  TCP    0.0.0.0:3268           0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:3269           0.0.0.0:0              LISTENING       444
  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       5424
  TCP    0.0.0.0:5049           0.0.0.0:0              LISTENING       1508
  TCP    0.0.0.0:6051           0.0.0.0:0              LISTENING       2788
  TCP    0.0.0.0:6150           0.0.0.0:0              LISTENING       1484
  TCP    0.0.0.0:8400           0.0.0.0:0              LISTENING       2912
  TCP    0.0.0.0:8402           0.0.0.0:0              LISTENING       4216
  TCP    0.0.0.0:8530           0.0.0.0:0              LISTENING       4
  TCP    0.0.0.0:8531           0.0.0.0:0              LISTENING       4
  TCP    127.0.0.1:389          127.0.0.1:1053         ESTABLISHED     444
  TCP    127.0.0.1:389          127.0.0.1:1054         ESTABLISHED     444
  TCP    127.0.0.1:389          127.0.0.1:1055         ESTABLISHED     444
  TCP    127.0.0.1:389          127.0.0.1:4098         ESTABLISHED     444
  TCP    127.0.0.1:1051         127.0.0.1:1052         ESTABLISHED     2912
  TCP    127.0.0.1:1052         127.0.0.1:1051         ESTABLISHED     2912
  TCP    127.0.0.1:1053         127.0.0.1:389          ESTABLISHED     3256
  TCP    127.0.0.1:1054         127.0.0.1:389          ESTABLISHED     3256
  TCP    127.0.0.1:1055         127.0.0.1:389          ESTABLISHED     3256
  TCP    127.0.0.1:4098         127.0.0.1:389          ESTABLISHED     2736
  TCP    127.0.0.1:5152         0.0.0.0:0              LISTENING       3280
  TCP    127.0.0.1:5152         127.0.0.1:2590         CLOSE_WAIT      3280
  TCP    192.168.67.229:80      192.168.67.229:2674    TIME_WAIT       0

Open in new window

0
DonNetwork AdministratorCommented:
Do you have a website running on this DC ? Sharepoint ?
0
SmallPrintAuthor Commented:
Nothing. Sharepoint is on another physical server.

When I go to http://servername/, i get the "it works" message....doesnt that mean nothing is really running on 80?
0
DonNetwork AdministratorCommented:
You should get a "Under Construction" page
0
SmallPrintAuthor Commented:
would reinstalling IIS help us exclude any other sites working on port 80?
0
SmallPrintAuthor Commented:
this DC is also a DNS server....
0
DonNetwork AdministratorCommented:
It looks as if you have Frontpage or Dreamweaver on this server.

0
DonNetwork AdministratorCommented:
Try uninstalling/reinstalling IIS so that you can get the "Default Website" started
0
SmallPrintAuthor Commented:
We are getting VERY close to fixing this.

SubVersion was installed. I uninstalled it, and now when I visit http://servername/, I get "you are not authorized to view this page" 401.1

.   The default website is now running.  My local machine still wont update though.
0
SmallPrintAuthor Commented:
uninstall/reinstall IIS and WSUS ?
0
DonNetwork AdministratorCommented:
You need to see "Under Construction" so it looks like permissions
0
DonNetwork AdministratorCommented:
"uninstall/reinstall IIS and WSUS ? "

Well you got the default website running, so not quite yet
0
DonNetwork AdministratorCommented:
Why dont you go ahead and reinstall IIS and make sure ASP.NET gets installed as well.
0
SmallPrintAuthor Commented:
removing and reinstalling now.
0
DonNetwork AdministratorCommented:
If there are still problems, I would also reinstall WSUS. Hopefully you wont have to.


http://blogs.technet.com/b/sus/archive/2008/11/05/how-to-manually-remove-all-of-wsus.aspx 
0
SmallPrintAuthor Commented:
just reinstalled IIS...same permission error (401.1).
0
SmallPrintAuthor Commented:
reinstalling WSUS now.
0
SmallPrintAuthor Commented:
i reinstalled WSUS...still get 401 error.


When i try to update my client, i now get error 80072EFD
0
SmallPrintAuthor Commented:
i also reinstalled WSUS all under port 80...so now there is just the default site in IIS.

0
DonNetwork AdministratorCommented:
When you uninstalled WSUS, did you follow the article above or just use add/remove?


Check....

http://social.technet.microsoft.com/wiki/contents/articles/wsus-troubleshooting-survival-guide.aspx
0
SmallPrintAuthor Commented:
Add/remove. I'll read the article.

Regardless if wsus is installed or not, shouldnt http://servername still show an under construction page?
0
DonNetwork AdministratorCommented:
Yes
0
SmallPrintAuthor Commented:
when we talk about permission for IIS, do you mean the section titled "IIS Settings" in bold @ http://technet.microsoft.com/en-us/library/cc708545%28WS.10%29.aspx  ?

0
SmallPrintAuthor Commented:
This is crazy.

I followed steps in the 2nd post, changed permissions to windows integtrated...now my desktop appears in the WSUS admin util. My desktop is now pulling updates.

http://www.wsus.info/index.php?showtopic=5928
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonNetwork AdministratorCommented:
Well there you go, you should be set
0
SmallPrintAuthor Commented:
Going against Microsoft documentation, adding Windows Integrated permission actually fixed my issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.