<modules runAllManagedModulesForAllRequests="true"> causes postback links to fail in DNN 5.6.2

Some time ago, we added runAllManagedModulesForAllRequests="true" parameter to web.config <Modules> section of <system.webServer> so that extensionless URL's could be used (IIS7, ASP.NET 4 Integrated Mode). If I remove this parameter and just have
<system.webServer>
<modules>
....
....
</modules>

the DNN links work on the home page, but now all my extensionless URLs break with a 404 page not found error. How do I get BOTH extensionless URLs AND DNN postback links to work?? This is just been broken in 5.6.2 as this worked before.
cwruckAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cwruckAuthor Commented:
Finally, problem solved.

There is a bug in IIS 7.0 and 7.5 with ASP.NET 4.0 Integrated Pipline Mode where the wild card http handler is not being correctly handled for extensionless http requests.  As a workaround, people have been using the sledge hammer approach (as we did) by specifiying <module runAllManagedModulesForAllRequests="true"> in the <system.webServer> section of web.config, so that the urlrewriter module could take care of the extensionless urls.

Now this used to work for a while in DNN, but something has recently changed in DNN which was causing postback link urls to be blocked when using this modules parameter. Microsoft have released a hot fix for this problem http://support.microsoft.com/kb/980368 which is also included in the Windows Server 2008 R2 SP1.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cwruckAuthor Commented:
I found the solution - install the hotfix or SP.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.