We help IT Professionals succeed at work.
Get Started

recovery password cisco router 3945

memo12345678
memo12345678 asked
on
7,398 Views
Last Modified: 2012-05-11
Dear Cisco ,

I buy new Cisco router 3945 first time booting I put user and password cisco after I make reboot and save I did not change anything now I cannot login router said wronge username and password , before username and password is cisco
How I make recovery password for this router  !!

yourname(config)#do wr t
Building configuration...

Current configuration : 4966 bytes
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
!
crypto pki trustpoint TP-self-signed-3926682494
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3926682494
revocation-check none
rsakeypair TP-self-signed-3926682494
!
!
crypto pki certificate chain TP-self-signed-3926682494
certificate self-signed 01





  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33393236 36383234 3934301E 170D3131 30323039 30373334
  33325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39323636
  38323439 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A8F1 CE734E91 1863058C CACF2B9D 85E47C9F A66899F8 3286F764 EDE5D899
  0FD2D55C 613776CE B402C9B1 227ABE1B 6D56AD7E C017E234 9519B689 EFCB7A38
  68A0A3C2 E46EA957 7F8EF4E1 1B64849A 9F4DB907 94A5D116 57532A4D 34B0E5BD
  F32C5012 3242508B CA2418FE 69D90D61 BCB3E681 CB6B0742 574DF8A5 85F2B85E
  F87D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 144A2C76 B26EDE64 F060AD8B 20712E1F BD325670
  89301D06 03551D0E 04160414 4A2C76B2 6EDE64F0 60AD8B20 712E1FBD 32567089
  300D0609 2A864886 F70D0101 04050003 81810053 6B2B152E 050A530E ED7A0461
  E1AD85D8 416F666E 8DCBA173 73DC5537 C821354D 473C3020 483C814D 795C7B94
  6892F061 929F2435 3144AC15 E63D61D5 EB3A9AA5 EFAA08D5 24509D20 22B617B0
  80E53C27 A80C1D6F F8D6FEF8 B71EAF55 EBAFA3A4 F2F67462 57859F0A E55DB308
  9891AC61 D5C64B2C 791EB95B FDF27E1B E870AD
        quit
license udi pid C3900-SPE150/K9 sn FOC14495EQ7
hw-module sm 1
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.10.10.1 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet1/0
no ip address
shutdown
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for  one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.


username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
login local
line aux 0
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1    
 flowcontrol software
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end


Comment
Watch Question
Head of IT Security Division
CERTIFIED EXPERT
Top Expert 2010
Commented:
This problem has been solved!
Unlock 1 Answer and 12 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE