SharePoint Changes Not Applied Across All Servers

I have made some custom webparts and pages that I have deployed into my SharePoint environment. The SharePoint environment is a load balanced server architecture.

For some reason all changes that have been deployed have been applied to all the servers apart from one. So this server is showing an older version of functionality.

Does anyone have an idea what is causing this to happen?
R1ND3RAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bradgcozaCommented:
Have you run any upgrades recently and not run SharePoint Configuration Wizard on that server so the upgrade has not completed?
0
R1ND3RAuthor Commented:
No upgrades have recently been made.

Everything seems to be working fine when viewing the intranet on that server. It just seems like my updated modifications are getting pushed through.

When deploying my solution through Central Admin, it says my files have been deployed to that server.
0
bradgcozaCommented:
And all the SharePoint Server versions are the same and all the architectures are the same (x64 and x86)

?
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Justin SmithSr. System EngineerCommented:
have you tried to retract and redeploy?  is the timer service running on that box?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
R1ND3RAuthor Commented:
Hi ACH1LLES,

I have tried numerous retracts and redeploys to try and get the changes made.

I will check the timer service.
0
bradgcozaCommented:
Are there any obvious error logs in event viewer on the server that is not working?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.