Using Blat to try send email notifications

Hi Experts,

Im trying to use Blat.exe to send emails internally.

SBS Server 2008, Exchange 2007

Here is the cmd:

Blat -body "test" -to TESTRelay@company.co.uk -server ServerName.domain.local -subject "Test Email" -f Test.Notifications@company.co.uk -u user.name -pw password

The output of which is:

c:\Windows\System32>Blat -body "test" -to TESTRelay@company.co.uk -server ServerName.domain.local -subject "Test Email" -f TESTNotifications@company.co.uk -
u Test.Notifications -pw password
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19)

Sending stdin.txt to TESTRelay@company.co.uk
Subject: Test Email
Login name is TESTNotifications@company.co.uk
The SMTP server does not require AUTH LOGIN.
Are you sure server supports AUTH?
The SMTP server does not like the sender name.
Have you set your mail address correctly?
Error: Connection to server was dropped.

c:\Windows\System32>


Additional Info:

Test.Notifications is a valid user, i can login to email and send and receive msgs. The email address for this user is TESTNotifications@company.co.uk.

I have tried alternate users to authenticate, same thing.

LVL 1
dt3itsteamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunnyc7Commented:
Please configure SMTP connectors as outlined in the article below and try again.
http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dt3itsteamAuthor Commented:
Hi sunnyc7,

I followed that link above but went with option two, i dont need external access.

I ran blat again and now have this:

c:\Windows\System32>Blat -body "test" -to TESTRelay@company.co.uk -server ServerName.domain.local
-subject "Test Email" -f TESTNotifications@company.co.uk -
u TEST.Notifications -pw password
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19)

Sending stdin.txt to TESTRelay@company.co.uk
Subject: Test Email
Login name is TESTNotifications@company.co.uk
The SMTP server does not require AUTH LOGIN.
Are you sure server supports AUTH?
The SMTP server does not like the name TESTRelay@company.co.uk.
Have you set the 'To:' field correctly, or do you need authorization (-u/-pw) ?
The SMTP server response was -> 550 5.1.1 User unknown


c:\Windows\System32>

Strange that it doesn't like the TO email address? That one i am using is just a DL i have setup. Why would u need authentication for that?
0
sunnyc7Commented:
Is
TESTNotifications@company.co.uk a DL address ?

Can you change that to an address which is a member of the dl and try again ?
Also, can you restart Microsoft System Attendant and Transport Service
0
dt3itsteamAuthor Commented:
TESTNotifications@company.co.uk is a Mail-Enabled Universal Distribution Group

Members include:

"Design" - Mail Enabled Universal Security Group
"Contact1" - Mail Contact

I tried changing the TO field to user1@company.co.uk (part of Design Group) and got this:

c:\Windows\System32>Blat -body "test" -to user1@company.co.uk -server ServerName.domain.local
-subject "Test Email" -f TESTNotifications@company.co.uk -
u TEST.Notifications -pw password
Blat v2.6.2 w/GSS encryption (build : Feb 25 2007 12:06:19)
Sending stdin.txt to user1@company.co.uk
Subject: Test Email
Login name is TESTNotifications@company.co.uk
The SMTP server does not require AUTH LOGIN.
Are you sure server supports AUTH?
Message not accepted by server

c:\Windows\System32>


I also restarted those two services and tried it all again with the same results.
0
dt3itsteamAuthor Commented:
I have checked the following on the properties of the connector:

Authentication: TLS (ticked already) and Basic Authentication

Permission Groups: Anon Users (Already Checked), Exchange Users and Exchange Servers.

Test email now works ok!

Thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.