WSUS Website cannot start in IIS

I have a SBS 2008 server that was installed a few months ago.  Everything had been working great during this time including updates from WSUS.  The SBS console began reporting that the update status was unavailable.  I began looking around and found that the "WSUS Administration" web site was stopped in IIS and could not be started.  The error message I get is  "The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)"  

The site is set to use the default ports of 8530 and 8531.  I ran a netstat command and found the following lines:

Proto  Local Address                   Foreign Address        State           PID
TCP    0.0.0.0:8531           0.0.0.0:0              LISTENING       2352
TCP    [fe80::5175:e1d:1f75:fa1d%12]:8806  [fe80::5175:e1d:1f75:fa1d%12]:8531  ESTABLISHED     4824
TCP    [fe80::5175:e1d:1f75:fa1d%12]:20339  [fe80::5175:e1d:1f75:fa1d%12]:8531  ESTABLISHED     5136
TCP    [fe80::5175:e1d:1f75:fa1d%12]:59341  [fe80::5175:e1d:1f75:fa1d%12]:8531  ESTABLISHED     1896

The PID's for each of these refer to Exchange services and are as follows:
2352 - store.exe
4824 - Microsoft.Exchange.ServiceHost.exe
5136 - EdgeTransport.exe
1896 - ? (not listed in task manager of the server)

The resulting event log entries are:
"Unable to bind to the underlying transport for [::]:8530. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine.  The data field contains the error number."
"Windows Update failed to check for updates with error 0x80072EFD."
"The API Remoting Web Service is not working."
"The Reporting Web Service is not working."
"Self-update is not working."
"The Server Synchronization Web Service is not working."
"The DSS Authentication Web Service is not working."
"The SimpleAuth Web Service is not working."
"The Client Web Service is not working."

It seems the WSUS ports are bound to Exchange for some reason.  I have not been able to find much about the issue on the web.  I do have a sonicwall and have added all of the windows update URLs to the exception list for the content filter.  I can browse to http://update.microsoft.com in the browser and it redirects to the update application on the server like it is supposed to do.

I have a reboot scheduled which may resolve the issue, but I want to have a solution in case that does not fix it or the issue returns at a later time.

Any ideas would be appreciated.  thanks!
bobbailey22Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DonNetwork AdministratorCommented:
0
bobbailey22Author Commented:
I tried the WSUS Repair guide, but could not get past step 4.  Since the WSUS website is not started, the server is not listed when I open the WSUS management program and cannot be manually added due to the error: "Cannot connect to <name> The server may be using another port or different SSL setting."

The second article had a lot of information but none was able to resolve the problem.  I tried the repair of WSUS here:  http://technet.microsoft.com/en-us/library/dd443475%28WS.10%29.aspx
Via this command:
X:\CMPNENTS\wsus\wsussetup.exe /q DEFAULT_WEBSITE=0 CREATE_DATABASE=1 CONTENT_LOCAL=1 CONTENT_DIR=D:\WSUS WYUKON_DATA_DIR=D:\WSUS
But nothing happened when the command was executed, it just came back to the prompt immediately.

I think the issue is still with the port conflict with Exchange that is preventing the WSUS website from starting in IIS.  Do you know how to resolve that or change the ports in WSUS?
0
DonNetwork AdministratorCommented:
Can you manually start the Website ?

post your wsussetup.log

Lets try recreating/creating the default selfupdate virtual directory under port 80 by running the  installselfupdateonport80.vbs


http://fawzi.wordpress.com/2008/08/05/troubleshooting-client-self-update-issues/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Top Threats of Q1 & How to Defend Against Them

WEBINAR: Join WatchGuard CTO and our Threat Research Team on Aug. 2nd to hear the findings from our Q1 Internet Security Report! Learn more about the top threats detected in the first quarter and how you can defend your business against them!

bobbailey22Author Commented:
The website will not start manually, the error code is listed above. (0x80070020)

The WSUSSetup.log only contains entries from when I ran that last command:
2011-03-30 13:04:37  Error     MWUSSetup          Product is already installed. Setup type specified is inconsistent with allowed action (Error 0x80041453)
2011-03-30 13:04:37  Success   MWUSSetup          The command line parameters specified are invalid
2011-03-30 13:04:37  Error     MWUSSetup          DoInstall: ParseCommandLine failed (Error 0x80041453)

Steps 1-2 on the suggested website were OK: The command in the article worked: "Success: InstallSelfUpdateOnPort80 succeeded"  (On a side note, this is where the vbscript file was found on my server: C:\Program Files\Update Services\setup\installselfupdateonport80.vbs)

Step 3 advises to check the logs in this folder: %windir%\system32\LogFiles\W3SVC1 But the only folder I found by that name was here (C:\inetpub\logs\LogFiles\W3SVC1)  I have attached the most recent log to this thread.

Step 4, I can browse to these locations: http://WSUSServerName/iuident.cab and http://WSUSServerName/selfupdate/AU/x86/osvariable/languagevariable/wuaucomp.cab

Step 5, the clients were contacting the server before it stopped working, the issue is the web site, not the clients.

Step 6-7 do not apply.

After running the VB script above, the web site still does not start.  I will reboot the system this evening and see if that helps solve the problem.

Any other suggestions are welcomed.

Thanks!
u-ex110330.log
0
bobbailey22Author Commented:
Nice Job
0
bobbailey22Author Commented:
The vbscript file seemed to have fixed it after a reboot of the server.  I also had to remove SSL from some of the directories within the WSUS website that I had added per another article I read.
0
juttaReimannCommented:
Recently had the same problem, in my case the WSUS port 8530 was being used by msExchangeMailSubmission.exe

To find what is using port 8530 follow this procedure:

Run the following command from a command prompt to find the PID of the process which is using TCP port 8530
 
               netstat -aon | find ":8530"

 You will see an output similar to the following. Remember the actual PID will vary from case to case.
 
               TCP    0.0.0.0:8530             0.0.0.0:0              LISTENING       3604

Open Task manager and identify the process with the corresponding PID.

In my case it was simple enough then to stop the msExchange MailSubmission service, kill the process, start the WSUS website, then restart the Mailsubmission service.

Hope this helps.
0
DonNetwork AdministratorCommented:
@juttaReimann

You are commenting on an already closed question, Your comment(S) will most likely be ignored since there is already a verified accepted answer http:#a35264096
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.