AutoQOS for Shoretel Phone System

Good Afternoon,
We are currently in the process of implementing a new Shoretel VoIP Phone system in our
network.  We have a Cisco Catalyst 6506e at the core for routing and Cisco Catalyst 2960S
switches at the edge for all client connections. We'd like to enable AutoQOS on our
switches for VOIP traffic but I’m uncertain on whether this is strictly a feature Cisco
phones (not Shoretel) and whether our 6506e switch will support it.

Here is an overview of our network
SHORETEL SERVER VLAN (Cisco 2960s)
172.16.0.0/24

DATA NETWORK
192.168.0.0/16

BO VLAN (Cisco 2960s)
VOICE -172.16.10.0/24
DATA - 192.168.10.0/24

The Shoretel phones we're using are IP230g, the clients workstation will connect directly
to the phone and then the phone connects to the 2960s switch.  The phone will acquire a
DHCP address from our DHCP on the Data Network

From what I gather here is what i would need to change at the Edge:

Existing port configuration...
interface GigabitEthernet1/0/3
switchport access vlan 10
switchport mode access
switchport port-security
switchport port-security aging time 5
switchport port-security violation restrict
switchport port-security aging type inactivity

New Port Configuration...
interface GigabitEthernet1/0/3
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native 10
mls qos trust dscp
auto qos voip trust
switchport nonegotiate
switchport port-security
switchport port-security aging time 5
switchport port-security violation restrict
switchport port-security aging type inactivity

Unfortunately, i'm not sure what need to change at the core level to support AutoQOS.

Thanks in advance!
ebs_itAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Soulja53 6F 75 6C 6A 61 Commented:
Why configure the access ports as trunks?

You can instead:

interface GigabitEthernet1/0/3
switchport access vlan 10
switchport voice vlan x
switchport mode access
mls qos trust dscp
auto qos voip trustmls qos trust dscp

switchport port-security
switchport port-security aging time 5
switchport port-security violation restrict
switchport port-security aging type inactivity

The core will definately support it. Just enable qos and apply  mls qos trust dscp and
auto qos voip trust on the trunk ports connecting to the 2960's . You may need to apply on the 2960 trunks also leading to the core.



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.