User profile names missing on XP Welcome Screen

Hi, trying to repair an XP Media Centre version on laptop following virus/spyware infection.  All now ok, except for all but one user account name listed on the welcome screen not appearing, although 3 actual users are listed in the "Users" in control panel.

Not come across this before, any ideas?  I have tried removing one of the profiles after backing up the data, generated a new profile account but this doesn't appear, just one account on login which gives a password prompt - which ironically is bypassed by pressing enter (control panel suggests no password).

Many thanks.
mpcs_plymouthAsked:
Who is Participating?
 
MaximumIQCommented:
hold down Alt + Ctrl and press Del twice then release Alt + Ctrl. This should take you to the NT style login. Try typing in the username manually in there and see if you can login. Let me know if that works.
0
 
MaximumIQCommented:
I should have just posted this to start with, but if the login does work. then check this open the Registry Editor (Start => Run => Regedit) browse to the following container
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList

If you see an entry on the right side in that container where the name of the entry is the hidden username, delete it then reboot and that should take care of it.
0
 
mpcs_plymouthAuthor Commented:
Hi MaximumIQ: Yes that seems to work fine, never thought of trying that method, it doesn't show the icons on the welcome screen as per normal XP/Vista, but least it will work!

Any tips on bringing back the welcome screen icons?

Thanks.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
mpcs_plymouthAuthor Commented:
Hi also tried your 2nd posting, no relevant user accounts listed...

Finishing now - 23.45 UK time, will continue tomorow am :)
0
 
MaximumIQCommented:
go to the registry container in my last post
Add a value as a DWORD and name it with the username in question then set the value to 1

Hopefully this will override whatever is hiding it
0
 
arnoldCommented:
open user accounts control panel.
navigate to Change the way users logon and logoff.
Enable the Use the welcome screen.
http://www.techwarelabs.com/community/showthread.php?t=1075
run:
control userpasswords2
Under Users make sure there is no check in the "users must enter a user name and password to use this computer."
Under advanced, make sure you do not have require users to press ctrl+alt+delete under the secure logon section.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.