Grant-CsSetupPermission error

stadarnet
stadarnet used Ask the Experts™
on
Hi,

I am installing Lync and I have OCS2007 R2 already installed on this domain.

When I run the,

Grant-CsSetupPermission –ComputerOU <DN of the OU> -Domain <Domain FQDN>

I get this error,

PS C:\Users\topdog> Grant-CsSetupPermission -ComputerOU "OU=Lync Servers" -Domai

n domain.local

WARNING: Grant-CsSetupPermission failed.

WARNING: Detailed results can be found at

"C:\Users\topdog\AppData\Local\Temp\3\Grant-CsSetupPermission-c5c55b0f-159e-49c

1-b476-3c9ec9dafc6f.html".

Grant-CsSetupPermission : Command execution failed: The security descriptor is

null. You might not have permissions to read the security descriptor.

At line:1 char:24

+ Grant-CsSetupPermission <<<<  -ComputerOU "OU=Lync Servers" -Domain domain.loc

al

    + CategoryInfo          : InvalidOperation: (:) [Grant-CsSetupPermission],

    ActiveDirectoryException

    + FullyQualifiedErrorId : ProcessingFailed,Microsoft.Rtc.Management.Deploy

   ment.GrantSetupPermissionsCmdlet

 

This is a clean install on  Windows 2008 r2, installing Lync enteprise, all privious steps done correctly by the book and completed normally.

I have tryed this command with more than one user account with enterprise admin priviledge with same result.

the C:\Users\topdog\AppData\Local\Temp\3\Grant-CsSetupPermission-c5c55b0f-159e-49c  looks like this,
Microsoft Lync Server 2010 Deployment Log  Collapse All Actions
 Action   Action Information   Time Logged   Execution Result
 ¿ Test-CSCertificateConfiguration         Completed with errors

 +    Connection: Data Source=(local)\rtclocal;Initial Catalog=xds;Integrated Security=True   26.3.2011 09:28:40    

 + ¿ Get Certificate      26.3.2011 09:28:40   Completed with errors

     +    Error: Missing certificate assignments.   26.3.2011 09:28:42   Error

 +    Command Status: Command processing is complete.   26.3.2011 09:28:42    

 + ¿ DeploymentXdsCmdlet.SaveCachedItems      26.3.2011 09:28:42   Success

     +    "0" updates   26.3.2011 09:28:42    

 +    Command Status: Command run is complete.   26.3.2011 09:28:42    
 

I have not started working with certificates yes?? It is in the next step.

Pls adv,
 
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Greg BessoIT Solutions Engineer

Commented:
Hello there stadarnet,
A few quick questions...

1) are you running this as a domain and/or enterprise administrator? If so you can skip that step: http://technet.microsoft.com/en-us/library/gg398225.aspx

2) Did you verify you meet the AD requirements? http://technet.microsoft.com/en-us/library/gg412955.aspx

Author

Commented:
Hi Whoajack,

yes I am running this as an domain user and enterprise aministrator

Author

Commented:
I am installing Lync on a Windows 2008 r2 domain, all servers ar Windows 2008 r2
I have only tried this entry
 Grant-CsSetupPermission -ComputerOu <DN of the OU or container where the computer objects that will run Lync Server reside > [-Domain <Domain FQDN>]

 I have not tried  the test or revoke,
Should I ?
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Greg BessoIT Solutions Engineer

Commented:
Just to clarify, I don't think you need to perform that step.
Start here and then move down the list...
http://technet.microsoft.com/en-us/library/gg398103.aspx

Author

Commented:
Hi,
I have completed  all the steps successfully  until I reach this step
Setting Up Front End Servers and Front End Pools
         Delegate Setup Permissions

I get error when I try to delegate setup permission
IT Solutions Engineer
Commented:
That is OK, you don't need to delegate permissions since you already have all the permissions that would be delegated. This is if you are going to let another user install Lync and they need specific permissions in order to do so.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial