Dual Monitor Problem on Windows 7

My pc is running windows 7 with nvidia geforce gt220 video card at dual monitor mode with extended display.

I have an LCD monitor (primary) connected to the dvi output and an LCD TV (secondary) connected to the vga output.

I turn the LCD TV off and turn it back on, it automatically switches to single monitor with the LCD monitor disabled. When I open the "Screen Resolution" at the control panel, only 1 display is detected (the LCD TV). But when I open the nvidia control panel (without doing anything else), the LCD monitor is automatically enabled and set back as the primary monitor.

How can I fix this?
LVL 22
ThomasianAsked:
Who is Participating?
 
bright12Commented:
I assume that you use the latest NVidia drivers?
0
 
ThomasianAuthor Commented:
Yes, I have the latest driver installed.
0
 
bright12Commented:
If you turn off the LCD TV it should be indeed going to 1 screen. When you turn the LCD TV on again (after a few minutes) will the system detects the LCD TV?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
ThomasianAuthor Commented:
Yes, it did detect the LCD TV. But it disables the LCD monitor. I would have to open the nvidia control panel and it would return to both displays without changing anything.
0
 
ThomasianAuthor Commented:
Also, I'm not really sure it detected that it was turned off. The screen resolution page still shows 2 displays and the monitor is still extended.
0
 
bright12Commented:
And there is now option in the nvidia control panel to 'remember' the setting?
0
 
bright12Commented:
Maybe you can try a Vista driver. This may could help.
0
 
ThomasianAuthor Commented:
It uses the same driver (installer) for both win 7 and vista
0
 
bright12Commented:
Try an older version to see if it's helping. It can be a bug in the drivers.
0
 
Harper-ITCommented:
If you press the Windows key + P, what do you see?  I am curious if the  "Extended" is the option that is highlighted.
0
 
ThomasianAuthor Commented:
I reinstalled the driver and that fixed the issue. Must have done something wrong the first time I tried?

Thanks for your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.