cisco 870w universal client

Hello experts.
I'm fairly new to Cisco routers and mostly use the sdm to configure my equipment.

I'm trying to set up a cisco 870w as a wireless universal client.
So far I've gotten the wireless the 870w to connect wirelessly as a client but my wired pc is unable to see anything on the parent side of the wireless connection.

I’m assuming that the Universal Client works similar to a Cisco Aironet Workgroup Bridge in that the wireless portion of the connection is transparent to the wired clients and they will be able to obtain their IP address from the DHCP on the parent side of the wireless network. Currently it doesn’t do this so I’ve programmed the IP manually.

Has anyone else experienced this or have any advice?
bongogeorgeAsked:
Who is Participating?
 
vikrantambhoreCommented:
Hello bongogeorge,

Can you please try below config, Please let me know if you need more help

dot11 ssid Parent1 (Wifi Name)
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 XXXXXXXXX (Password for Wifi Access)
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.2
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 10.10.10.1
   lease 0 2
!
ip domain name yourdomain.com
ip name-server 8.8.8.8      -----> DNS SERVER
ip name-server 4.4.4.4      -----> 2nd DNS  Server
!
bridge irb
!

ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 ip nat inside
 ip virtual-reassembly
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid Parent1
 !
  !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role non-root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 -----> should be WAN Interface
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Virtual-Dot11Radio0 overload
!
logging trap debugging
access-list 1 permit 0.0.0.0 255.255.255.0
no cdp run
!
!
!
control-plane

0
 
vikrantambhoreCommented:
Are you Comfortable to configure throu CLI (command Line Interface)


Vikrant
0
 
Craig BeckCommented:
0
 
bongogeorgeAuthor Commented:
Thank you for your replies and sorry for taking so long to get back with you.

Vikrant - For the past couple evenings I've been working on learning how the CLI works so the answer to your question is yes I am comfortable with the CLI.

craigbeck- Thank you for the link but I think my radio settings are good. Wireless connection between the client and parent seems to work fine. It's the link between the radio and Ethernet ports that doesn't seem to work.
------------------------------------------------------------------------------------------------------
If it helps here's my running config.... I think I'm close but just missing something that might be obvious to you.

ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
!
interface Dot11Radio0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 !
 encryption mode ciphers aes-ccm
 !
 ssid Parent1
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role non-root
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dot11Radio0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Virtual-Dot11Radio0 overload
!
logging trap debugging
access-list 1 permit 0.0.0.0 255.255.255.0
no cdp run
!
!
!
control-plane

0
 
bongogeorgeAuthor Commented:

Vikrant
Thank You for the configuration.
I'm still not able to get it to work.
It looks like it wants to work. When I try to access a webpage
from a computer on the Universal Client it talks to the parent radio but nothing comes up.

Can you check my config to see if I've done something wrong?
I noticed your config looks has a dsl interface for the WAN.
Mine uses a regular ethernet port FastEthernet4. Do I need to have it
set to a specific setting?
Thank You for your help!



dot11 syslog
!
dot11 ssid Parent1
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 11191817121C1F1C1721
!
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.2
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 10.10.10.1
   lease 0 2
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip bootp server
ip domain name yourdomain.com
ip name-server 68.87.73.246
ip name-server 68.87.71.230
!
!
!
username UniClient privilege 15 secret 5 $1$.40l$esLV5WHCa05zTc1Vih0UG1
!
!
archive
 log config
  hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description $ES_WAN$
 ip address dhcp client-id FastEthernet4
 ip route-cache flow
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 ip nat inside
 ip virtual-reassembly
 !
 encryption vlan 1 mode ciphers aes-ccm
 !
 ssid Parent1
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role non-root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 description $ES_LAN$
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
access-list 1 permit 0.0.0.0 255.255.255.0
no cdp run
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.