• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 501
  • Last Modified:

access ftp account using internet explorer

Dear Experts:

Iam having an  ftp accounts setup in linux and the clients use the microsoft internet explorer eariler with 5.5 and 6.0 through the ie i,e instead of http using ftp::// we were able to acces the ftp accounts but now with ie 8 we are not able to access the ftp account through the ie using ftp:// please suggest how to access the ftp account using the ie8. Thanks in advance.
0
D_wathi
Asked:
D_wathi
1 Solution
 
pilson66Commented:
0
 
upanwarCommented:
Could you please tell me exactly what error you are getting.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
LinuxGuruLinux Server AdministratorCommented:
Hi,

I have checked and was able to access ftp in IE8 using the following url.

ftp://ftp.domainname.com

or try to access using the above url in your windows explorer.
0
 
D_wathiAuthor Commented:
Thanks for the reply. from the internet when try to access the ftp account using the internet explorer(ftp:// user@ip address) iam getting an error message attached the error message for your reference please help. but when accessed from the lan ia was able to access. Please find rthe attached error message while tried access from the internet and help me to resolve this. Thanks in advance.
error-message.jpg
0
 
D_wathiAuthor Commented:
Hi experts:

Iam not able to login through the ie for the ftp,  attached error message for your reference.

error-while-accessing-through-th.jpg
0
 
upanwarCommented:
So you are saying that you can access the same ftp site from IE8 in the LAN and you are facing challenges while you are trying to access it from Internet.

Please correct me If I am wrong.
0
 
D_wathiAuthor Commented:
Yes sir you are correct, once i tried from the lan using private ip like ftp://user@192.168.1.3 then i was able to login and access the ftp account . But iam unable to login through the ie8 from the internet please help me to resolve this. Thanks in advance.
0
 
upanwarCommented:
From LAN as well you are accessing your ftp through IE8?

If yes then please show us below given output from your ftp box.

# iptables -L -v
0
 
D_wathiAuthor Commented:
Sir, Iptables is disabled but in the gateway we have a hardware firewall (fortegate) to access the ftp account through the ie what port or waht should eb done the this hardware firewall please suggest. Thanks in advance.
0
 
upanwarCommented:
Port 21 for the command port and port 20 for the data port, check whether they are open or not.
0
 
D_wathiAuthor Commented:
Sir, tahnks for the reply. Iam sure these ports are open because we access the server using the ftp client application from the interent only problem while accessing through the ie browser. My  boss wants to access the ftp through the ie browser. Please suugest.
0
 
upanwarCommented:
Thanks for your detailed reply, I was just going to ask you to test with ftp client. :)
0
 
upanwarCommented:
Could you please add your ftp site in trusted sites in Internet Explorer.

Tools --> Internet Options ---> Security ---> Trusted Sites

Here add your ftp URL.

If the above solution is not working then try the below given solution as well.


Click Tools, and then click Internet Options.
Click the Advanced tab.
Under Browsing, Click to select the Enable FTP folder view (outside of Internet Explorer) check box, and then click OK.
In Windows Explorer, enter the URL of the FTP site, and then press ENTER.


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now