Exchange 2010 Active Sync Iphones & Test Exchange connectivity

Hi All,

I've got issues getting my iphones to sync, someone has changed something but I cant find out what.

The test connectivity tool works until the final step then throws this error.

An ActiveSync session is being attempted with the server.
  Errors were encountered while testing the Exchange ActiveSync session.
   Test Steps
   Attempting to send the OPTIONS command to the server.
  Testing of the OPTIONS command failed. For more information, see Additional Details.
   Additional Details
  An HTTP 403 forbidden response was received. The response appears to have come from IIS7. Body of the response: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>403 - Forbidden: Access is denied.</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;}
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;}
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
background-color:#555555;}
#content{margin:0 0 0 2%;position:relative;}
.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
-->
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
<div class="content-container"><fieldset>
<h2>403 - Forbidden: Access is denied.</h2>
<h3>You do not have permission to view this directory or page using the credentials that you supplied.</h3>
</fieldset></div>
</div>
</body>
</html>
 
 
What I've done so far.

1. Checked the auth settings on the virtual directories against a server I know works (although Im happy for someone to tell me what these should be)
2. Applied SP1 for Exchange 2010.
3. If I browse to the active sync site in IE I am prompted to auth and the same user and password works fine.

Please save me from another all night session with the test exchange connectivity site.

Lee
 
e--manAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MegaNuk3Commented:
Check your ActiveSync VD and see if it is redirecting anywhere. In IIS manager select the ActiveSync VD in the left pane and then in the middle pane find the "HTTP redirects" option and see if it is redirecting.

Is /owa working properly on your server? If you use Outlook anywhere is that working too?
0
MegaNuk3Commented:
Check the inheritable permissions on the account as per this question :
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26752151.html
0
e--manAuthor Commented:
Cheers,

OWA Works fine in browser and on iphone. outlook anywhere not working.

No ReDirects in IIS

Lee

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

MegaNuk3Commented:
Here is a direct link to alanhardisty's article:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2861-Activesync-Working-But-Only-For-Some-Users-On-Exchange-2007-2010.html

So if it works and you accept this comment he will get 500 points for his article, which is nice of me ;-)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
e--manAuthor Commented:
Ok, I have no idea how but it started working this afternoon for 90% of users, I suspect the other just need the above AD setting correcting, thanks for your help
0
MegaNuk3Commented:
No problem
0
Alan HardistyCo-OwnerCommented:
Thanks MegaNuk3

Alan
0
MegaNuk3Commented:
@Alan - you are always welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.