UDL files will not open

I have a costumer with a LOB running in the native Microsoft Data Access service (please notice that this is native to Windows Server and has nothing to do with Microsoft Office Access)  
The application has  a databasefile called PROGRAM.UDL.
When double clicking this file NOTHING happens!
I can confirm that the file type is associated with "Microsoft Data Access - OLE DB Core Services"

When i duble click a similar file on another server SERVER2, it opens up correctly showing Data Link Properties. This is normal behavior.

Any ideas? :-)

OhmitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chev_PCNCommented:
Try re-setting the default application for the UDL extension.
Right click on the UDL file & choose "open with". Initially set it to notepad, and tick the "Always use selected program: option. Verify that double-clicking now opens up the file in Notepad, then repeat the process and re-set it back to "OLE DB core services", again ticking the "Always use" option.
OhmitAuthor Commented:
Hi Chev

Have tried - does not help.
pt I am trying to reinstall Server 2003 SP2.
This could be a problem with the OLEdb32.dll
Chev_PCNCommented:
Did you try re-registering that dll?
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

OhmitAuthor Commented:
Hi Chev

How do I re-registre a DLL?
Chev_PCNCommented:
from a cmd prompt run regsvr32 with the full path to the dll.

e.g. regsvr32 "C:\Windows\System32\oledb32.dll"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OhmitAuthor Commented:
Hi chev

it worked after reinstalling sp2.
I will close the case and award you the points for helping me and teaching me how to re-register dll's :-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.