Does anyone have any experience in deploying eDocs DM 5.3 x64 to windows 7 x64 with SCCM 2007.

I created a package in sccm and a program with this startstring msiexec /i eDocs DM 5.3(x64).msi /QR TRANSFORMS=Transform.mst. Im using this in a TASKSequence when installing the operative system. This working when running manually in a console. But i get MSI Error 1603 in SCCM.

Ive tried to use other switches like /Q /QB /QN but then the installation fails even when trying manually in a console .

Any clues why /QR fails only in sccm?

kihl71System EngineneerAsked:
Who is Participating?
 
KezziCommented:
I think the difference is when running with reduced UI, its running under user context, but with no UI, its using admin context.  That is why when you use QR from SCCM, which if you're running this from a task sequence really shouldnt be using the QR option, only QN.  

When SCCM runs msi installs as admin, its actually running under the System context.  The System context is different to the locally run Administrator account.  Both share the same administrator permissions and token levels, but the System account has no associated profile and has no user based registry.  Local Admin does have a profile associated with it, so if the application is writing loads of user based registry keys and files into Local Admin,  these are accessible to other users logging on.  With the System account, I have seen these types of installs fail as it cannot find the area of the user profile to write to.  These are very rare though and it depends on the manufacturer of the msi as to how their product installs.   One thing you can try is to add this on the command line:

ALLUSERS=1
0
 
KezziCommented:
Are you deploying this while a user is logged on?  If you're opting for Reduced UI without interaction is it so that the user can see an installation running?

Add this to the end of your command line to extract verbose logging for the msi.  This will help us identify what the error is.  1603 can be pretty generalised, but could be missing prerequisites, newer version already installed, unable to upgrade/repair/uninstall existing version, application in use etc.

msiexec /i eDocs DM 5.3(x64).msi /QR TRANSFORMS=Transform.mst /l*v c:\windows\temp\edocs.log

attach the log file here when done so I can see it.
0
 
kihl71System EngineneerAuthor Commented:
Thanks for quick response.

I attached a ZIPfile with logs fro two scenarios. Im loged in as a local admin  


DM-Install.-QR-.log.zip
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
kihl71System EngineneerAuthor Commented:
Posted to early. :)

I attached a ZIPfile with logs from two scenarios. Im loged in as a local admin and run the following strings.

msiexec /i eDocs DM 5.3(x64).msi /Q TRANSFORMS=Transform.mst /l*v c:\windows\temp\edocs.log
msiexec /i eDocs DM 5.3(x64).msi /QR TRANSFORMS=Transform.mst /l*v c:\windows\temp\edocs.log

The reason i used /QR in sccm is i cant get the installation to work with q or qb.

I will change the command line to msiexec /i eDocs DM 5.3(x64).msi /QR TRANSFORMS=Transform.mst /l*v c:\windows\temp\edocs.log in SCCM and deploy again then i post a new log file as you sugests.

It will take a while.

0
 
KezziCommented:
eDOCS DM CA: Feature, ImagingExt, is selected.
eDOCS DM CA: OT_SERIALNUMBER_28 property value = ""
eDOCS DM CA: OT_PASSWORD_28 property value = "********"
eDOCS DM CA: Feature, RMExt, is selected.
eDOCS DM CA: OT_SERIALNUMBER_32 property value = ""
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: RMServerFeature
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: DMServerFeature
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: ContentCacheFeature
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: ELIntegrationFeature
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: RMAdminFeature
MSI (s) (C8!94) [13:24:40:228]: Note: 1: 2711 2: DSSA
eDOCS DM CA: OT_PASSWORD_32 property value = "********"
eDOCS DM CA: UILevel=2
eDOCS DM CA: Feature, ImagingExt, failed pre-validation.
eDOCS DM CA: Terminating due to error during license checking for feature, ImagingExt.
CustomAction DLL_LicensePreValidate returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 13:24:40: DLL_LicensePreValidate. Return value 3.
Action ended 13:24:40: INSTALL. Return value 3.
0
 
KezziCommented:
In msi log files, when they fail, search for Return Value 3 and then read the lines above it.  This will tell you whats failing in the install.  Here its shows its failing the license check.  Have you entered the Serial number in it and is the password option correct?
0
 
kihl71System EngineneerAuthor Commented:
Thank you very much.

Its strange this error only occur when using /q for quiet but it works /using qr i mean both types is silent and unattended. Im using the same configuration i both scenarios.

0
 
KezziCommented:
can you step through these with the options \qn and \qb as well?  I'm interested to see how they differ in the log files.
0
 
kihl71System EngineneerAuthor Commented:
Sorry i havent had time to test everything yet. So i will get back to you tomorrow. Thanks for all help so far. Cheers
0
 
kihl71System EngineneerAuthor Commented:
Thanks for all help.

I finally found a bad solution to this problem. I have to use a batfile with the whole startstring. I even asked the following question to Opentext support.


********************************
I finally got this to work using a batfile. I change from /qr to /q in the batfile and it works. My first question was, Is it possible to deploy edcocs extension 64 in SCCM 2007? Now i know the the answer. it works.
 
msiexec.exe /i "eDOCS DM 5.3 Extensions (x64).msi" /Q ADDLOCAL="DMExtensionsAPIFeature,ExplorerNamespace,DynamicViewsFeature,Microsoft.Word.2010,Microsoft.Excel.2010,Microsoft.PPT.2010,Linking,Linking.Other,Linking.Word.2010,Linking.Excel.2010,Linking.PPT,OtherAppsFeature,Interceptor,OutlookClient.2010,Microsoft.Outlook.2010,DMViewer,CheckinCheckoutFeature" WORD_INTEGRATION_LEVEL="Active" EXCEL_INTEGRATION_LEVEL="Active" POWERPOINT_INTEGRATION_LEVEL="Active" DMSERVERNAME=servername /l*v %TEMP%\Install_DM5.3.log

Instead of using parameters on command line i tried customize a mst file with following settings.

Feature
DMExtensionsAPIFeature Default 1
ExplorerNamespace Def 2 Changed to 1
DynamicViewsFeature Def 2 Ch 1
Microsoft.Word.2010 Def 0 ch 1
Microsoft.Excel.2010 Def 0 ch 1
Microsoft.PPT.2010 1 Def 0 ch 1
Linking Def 2 ch 1
Linking.Other Default 1
Linking.Word.2010 Def 0 ch 1
Linking.Excel.2010 Def 0 ch 1
Linking.PPT Def 0 ch 1
OtherAppsFeature Def 2 ch 1
Interceptor Default 1
OutlookClient.2010 Default 1
Microsoft.Outlook.2010 Def 0 ch 1
DMViewer Def 2 ch 1
CheckinCheckoutFeature Def 0 ch 1

Propertys
WORD_INTEGRATION_LEVEL="Active" Default
EXCEL_INTEGRATION_LEVEL="Active" Default POWERPOINT_INTEGRATION_LEVEL="Active" Default


Then I tried to execute the following line with msiexec /qr Msifile TRANSFORMS=mstfile.mst DMSERVERNAME=vingedm5. The installation fails from sccm but works when logged in as administrator locally.

So I changed from /QR to Q and it didn't work in SCCM or when run locally.

I also tried to edit the org msi packet with orca same settings as above. This worked worked with /q when running locally but not when run from sccm.

Do you have any documentation on howto deploy eDocs Extensions 5.3 best practice in sccm 2007?
***************************
This is the answer i got.

The only information I've been able to find on deploying DM with SCCM is the presentation you referenced, I assume you already have a local copy of the material, but if not it is available here-:
https://knowledge.opentext.com/knowledge/llisapi.dll?func=ll&objId=18452
469&objAction=browse

SCCM is one of several deployment utilities mentioned as usable for deploying DM, generally speaking we would normally refer users to the supplier of a third party application such as this for best practices regarding, or advice on working around issues specific to, that software.

Regards,

Peter

OpenText Support Team
**************************






0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.