FTP Binding

Hi

I have change the binding of my FTP site from 21 to 23. Redirect in my router from 21 to 23. The problem is that now I cannot enter in my FTP directories. I'm connecting but never see the directories.I have a response like: The server as return an unreturnable adress, repace by the servers adress.

Is there a place that I have to change port elsewhere that in IIS an the router?

Thanks

Jean-Pierre
jpmoreauAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Firmin FrederickSenior IT ConsultantCommented:
hi there

I have change the binding of my FTP site from 21 to 23

 - port 23 is used for telnet sessions - even if you redefine this in your router and in IIS you are ultimately sending the wrong data type down that line.  In addition other clients and ftp products will know this is an error and will return messages such as you are receiving.

Redirect in my router from 21 to 23

- it is likely that redirecting traffic like this on your router will either be mistaken as an attack on port 23 or just return an error.

Are you attempting to change from Active to Passive?  Are you using IIS7 and your clients are faling to connect?  Change your data connection type in your client to overcome this problem - leave your ports as they are or read how to configure active ports:

http://www.velikan.net/iis-passive-ftp/
0
jpmoreauAuthor Commented:
Hi

I said port 23 but it can be any other port. Examples port 2323 or 2121. I just want to change the port because I have a software to install that is using port 21 and I can't change it.


Thanks.
0
Firmin FrederickSenior IT ConsultantCommented:
in IIS 7 there is the "ftp firewall support" page to set the ports.  You then need to enable those ports on Windows firewall both TCP and UDP.  Then you need to enable those ports on your firewall/router and allor port fowarding if you are hosting locally or "open ports" if it's outbound traffic.
0
jpmoreauAuthor Commented:
OK

I resolve my problem with a routeur that I can redirect.

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jpmoreauAuthor Commented:
Change the router and everything is OK
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.