Exchange QMail relay

Hello,

I expose my problem :

We have an Exchange 2003 server in which all the mailbox for all the company, france and european offices, are set up.
We would like to take out the "out of france" mailbox to a qmail server.

I have correctly managed to setup the relay between Exchange to Qmail. But when i try to send and email from a qmail account to a mailbox that is on the exchange server, as qmail does not know the user it returns me an error :


Hi. This is the qmail-send program at ns380761.ovh.net.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

I also configured my outlook to use a different smtp server, and it works , the problem is that i do not have any records of the sent mail.

Could someone help me please ?
mvicidominiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Barry GillChief of StaffCommented:
In postfix you would use a "fallback transport"
unfortunately I do not know how to do this for qmail specifically... but that might give you a heads up in the right direction...
mvicidominiAuthor Commented:
Thanks , i have tried to find it but without success.

Barry GillChief of StaffCommented:
ok, then a more laborius method is to create user lists.

Here, you will create a group of known recipients witha  transport rule to get to them.

The problem with this is that you are going to have to manage users in two locations...

What you want to do is easy on Postfix and requires a simple parameter, are you stuck on using Qmail or could you move to Postfix?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

mvicidominiAuthor Commented:
The thing is that qmail is the MTA that is provided by default by OVH when you use a dedicated server with plesk.

So , if i undertand the only way to manage this king of architecture is to have a user liste on the qmail server.
Or to broke plesk and to use postfix.



Barry GillChief of StaffCommented:
no - thats not the only way - thats just the only way I know how to help.
Delete this question and repost it as catagory plesk and qmail so that you attract the right skills to help.

mvicidominiAuthor Commented:
ok thanks a lot for your help
mvicidominiAuthor Commented:
I have installed Ubuntu 10.04 with postfix , could you please tell me what in the configuration of my main.conf to relay exchange messages.
Barry GillChief of StaffCommented:
ok, now you're talking my language

in the main.cf file you can add a parameter called fallback_transport

fallback_transport (default: empty)
 Optional message delivery transport that the local(8) delivery agent should use for names that are not found in the aliases(5) or UNIX password database.
 
The precedence of local(8) delivery features from high to low is: aliases, .forward files, mailbox_transport_maps, mailbox_transport, mailbox_command_maps, mailbox_command, home_mailbox, mail_spool_directory, fallback_transport_maps, fallback_transport and luser_relay.

you need to set it as:
fallback_transport = smtp:[x.x.x.x]

Open in new window


If you have multiple locations or multiple routes, you *may* also want to check out fallback_transport_maps, though these will mean you need to set up per user/group delivery rules and will make your management a bit painful.

fallback_transport_maps (default: empty)
 Optional lookup tables with per-recipient message delivery transports for recipients that the local(8) delivery agent could not find in the aliases(5) or UNIX password database.

The precedence of local(8) delivery features from high to low is: aliases, .forward files, mailbox_transport_maps, mailbox_transport, mailbox_command_maps, mailbox_command, home_mailbox, mail_spool_directory, fallback_transport_maps, fallback_transport and luser_relay.

For safety reasons, this feature does not allow $number substitutions in regular expression maps.

VERY important to note is that you MUST set your local_recipients_maps parameter to blank so that Pstfix does not always verify against the local recipient maps.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mvicidominiAuthor Commented:
Seems to work. The only thing is that my smtp gateway refused the connection:


 status=deferred (connect to 88.247.77.213[88.247.77.213]:25: Connection refused)
mvicidominiAuthor Commented:
Sorry but i'm a beginner with postfix how can i :
VERY important to note is that you MUST set your local_recipients_maps parameter to blank so that Pstfix does not always verify against the local recipient maps.

Barry GillChief of StaffCommented:
in the main.cf file there is a section called "local_recipient_maps"
tehre are usually three options there, the default (uncommented) is:
local_recipient_maps = proxy:unix:passwd.byname $alias_maps

Open in new window


you simply need to comment (#) it out and uncomment the line that says
local_recipient_maps =

Open in new window

Barry GillChief of StaffCommented:
sorry just in answer to this:
 status=deferred (connect to 88.247.77.213[88.247.77.213]:25: Connection refused)

the is probably because your relay settings/trusted network settings are incorrect.
change your mynetworks parameter to something relevant.

This site makes it quite easy to follow :)
http://www.linuxtopia.org/online_books/mail_systems/postfix_documentation/STANDARD_CONFIGURATION_README_003.html
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.