Iphone 4 setup on exchange - wont actuve sync all emails.

Hi Guys,

It took a some time but thanks to the help on there I got exchange to work, with the iphones, however i now find that it wont active sync all emails, it seems to let me send emails ok, and I have one phone that seems to fully sync ok.

There seems to be no event errors either. Is there a way to set how often the server will sync emails?.

Pleae feel free to tell me if I am going  completley the wrong direction.

Thanks
David.

David LoganDirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
The proof of the pudding is in OWA.  If you login to OWA and see the emails there but they are not on the Device, then delete the account on the phone and set it up again.

If they are on the phone and not in OWA - that also points to a problem with the phone.

On your iPhone if you go to Settings> Mail, Contacts, Calendar> Check the Fetch New Data settings - it should be set to Push.
0
David LoganDirectorAuthor Commented:
Hi Alan,

I can get onto OWA no problem. Will try and delete the email account and then restart the phone and see how it goes from there.

I seem to be getting some emails through now - We have 6 users on out sbs server and the email database if about 12gig, is it worth runnin a refrag on this to speed the email sync up, or am I talking rubbish.

The emails are set to push with no limit to sync, how often dose exchange run active sync against each mailbox?.

Cheers
David.
0
David LoganDirectorAuthor Commented:
Ok, So no jow with that, I still seem to be getting some through and not others. On the phones that seem to work there also seems to be an issue, with some emails going missing.

We use a file mamaganet system that moves emails form inbox to a sub folder of inbox this seems to work ok, but activeSync will miss some emails, or show them one then is you go back they will be missing. Hostoric emails are ok, the issue seems to be with new emails.

0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Alan HardistyCo-OwnerCommented:
Okay - Activesync maintains a connection between the device and the Exchange server, so that when a new message arrives in the mailbox of the user with the mobile device, a message is sent to the device asking it to sync - which it does.

Your problem could be related to anti-virus interference; specifically background / proactive scanning and the "Inconsistent Sync" section of my Exchange 2003 article describes the relevant registry key you need to add to stop this sort of problem:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
David LoganDirectorAuthor Commented:
Thanks Alan,

I have completed those steps now, will gve the server a reboot tonight and keep you updated. hopefully that will sort it.
Cheers
David.
0
David LoganDirectorAuthor Commented:
update:

We seem to be able to recieve emails to the phone from activesync only when the client machines are logged onto the network outlook open. Can this be changed to work at any time?.

I also have atcive sync error 3005:

Unexpected Exchange mailbox Server error: Server: [CMSERVER.CMDOMAIN.local] User: [***@cmp.org.uk] HTTP status code: [503]. Verify that the Exchange mailbox Server is working correctly.

0
David LoganDirectorAuthor Commented:
One other issue: We can only connect when using the office WIFI - when i turn this off, we cant connect using mobile data - is this an IP Issue?. the AS Tester APP is still able to connect when using mobile data.
0
Alan HardistyCo-OwnerCommented:
Okay  the problem with Activesync only working when Outlook is open is covered in the "Inconsistent Sync" section of my article - it is to do with Anti-Virus issues and you will need to add a registry key, or adjust your Anti-Virus software to enable Background / ProActive Scanning.

The 3005 errors are also covered in my article.  Please have a look at that section and check the KB article mentioned.  Make sure the settings are exact in IIS.

If you can only connect when using Wi-Fi - that suggests you are using an FQDN that isn't correct in DNS externally.  What are you using as the server name?
0
David LoganDirectorAuthor Commented:
We dont have a FQDN - if i change the server name to the external ip address of the router it works ok. Still having problems with connection however.

I followed the KB for 3005 and now cant connect - The error

3005
Unexpected Exchange mailbox Server error: Server: [CMSERVER.CMDOMAIN.local] User: [terry@cmp.org.uk] HTTP status code: [500]. Verify that the Exchange mailbox Server is working correctly

and

2050
Process IISIPM99CB1DC5-D133-47BB-A1F9-E9A9CECF1E0F -T 600 -AP "DEFAULTAPPPOOL (PID=8160). The shared memory heap could not be created.

Any ideas?

Thanks for all the help Alan.
0
Alan HardistyCo-OwnerCommented:
If you are now getting the HTTP 500 error - please follow that section in my article (Method 2 of KB883380) and then see where that takes you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David LoganDirectorAuthor Commented:
Dont know what happend, i had ro follow KB883380 and the create a new exchange-omo folder again!!.. Anway wall is working fine. Thanks for the help Alan.

I plan on moving the location of the exchnage store files - is there a correct way to do this?.

Thanks
David.
0
Alan HardistyCo-OwnerCommented:
Have a read of the following article for how to move the database / logs:

http://support.microsoft.com/kb/821915

Glad Activesync is working and thanks for the points.

Alan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.