Exchange 2003 /3GB crashes server on boot

EE

I have just built a new Windows 2003 32-bit R2 SP2 and installed Exchange 2003 Ent with sp2.  The system is a new Dell R710 which is 64bit hardware.  My problem is that when I add just the /3GB switch to the boot.ini file the system crashes on boot at CTRL+ALT+Del and goes into a loop of rebooting and crashing.  The same also happens with /3GB /userva=3030.  The best I can tell the issue is probably related to 64-bit hardware running 32-bit software, but I don't know what to do.  

Since I plan to add this Exchange 2003 to an existing Exchange 2000 Org, for the purposes of an interim step up to Exchange 2010, I really don't want to install a 64-bit version of the OS.

Any thoughtful comments appreciated.

LVL 5
JohnDemerjianAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cjrmail2kCommented:
You should not need to install the 64-bit OS. Those extensions should work. Have you checked the event logs?
0
JohnDemerjianAuthor Commented:
the event logs only know the previous shutdown was dirty.  the /3GB switch is meant to manipulate memory (I am guessing) for 32 bit hardware and OS only.  So i don't understand why it would work?  have you installed exchange on a 32 bit OS running on 64 bit hardware, used that switch and had it work?
0
cjrmail2kCommented:
No, the /3GB switch is for 32 bit OS, regardless of the hardware underlying it.

http://support.microsoft.com/kb/823440

If you remove the switch, does it boot fine?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JohnDemerjianAuthor Commented:
yes
0
cjrmail2kCommented:
How much RAM is in the machine?
0
JohnDemerjianAuthor Commented:
4GB
0
cjrmail2kCommented:
Very strange, this is exactly ho I am set up (with the USERVA=3030 switch). My server hardware is 64 bit (as is most hardware now days. Running Windows 2003 R2 SP2 and Exchange 2003 (SP2)

Have you installed SP2 for Exchange 2003?
0
NenadicCommented:
Change /USERVA=3030 to 2800 and see the difference.  If you succeed, increase it to /2900 and so on, until it crashes again.  If it crashes at 2800, reduce further to 2500 and so on until you arrive at the highest value where it won't crash.

What you are basically doing is adjusting the amount of User memory allocated to the system at the detriment of Kernel memory - lack of which is crashing your server.

Leave /3GB as is.
0
JohnDemerjianAuthor Commented:
i have already tried /3GB alone and with /userva and they both crash the OS.
0
NenadicCommented:
They need to work together. Different values of USERVA that I suggest should remove the problem.
So, start with /userva=2800, then work up if it doesn't crash or down if it does.
0
JohnDemerjianAuthor Commented:
All references I have read that discuss /3GB and /userva= resulting in a crash indicate they crash the inforamtion store, not the operating system on boot.  If you have documentation to the contrary I will give your suggestion a shot, but I have already tried 3030 and 2900 with the same result.

I appreciate the help.
0
NenadicCommented:
The system crash is likely due to insufficient Kernel memory. Reducing USERVA increases Kernel memory. If 2900 didn't work, try 2500 as a sufficiently low value to make a difference.
0
JohnDemerjianAuthor Commented:
http://support.microsoft.com/kb/810371

Note The /Userva parameter is only supported on Exchange servers when the value is set between 2,970 MB and 3,030 MB. Values that are less than 2,970 MB or greater than 3,030 MB are not supported. Only in extreme low PTE cases should a value that is less than 2,970 MB be used. The recommended default value for Exchange servers is 3,030 MB.

Do not modify the value to below /userva=2800 to try to gain more PTEs.
0
JohnDemerjianAuthor Commented:
Hi cjrmail2k

Sorry I missed your post a while back.  I had in fact installed SP2 for Exchange but then when I ran the BPA it told me I had an old mapi32.dll - a symptom of perhaps a bad SP2 install.  I re-ran SP2, fixed the MAPI32.dll problem and have not yet tried the /3GB switch again.  I will let you know.
0
cjrmail2kCommented:
Cool
0
JohnDemerjianAuthor Commented:
The SP re-install did not help.  I have given up on using this switch since it is not necessary in our case.  Thanks for your help.
0
cjrmail2kCommented:
Ok no problem, sorry that it didn't work out for you. I believe it must be an OS issue and if you have a test environment you may want to try reinstall everything and retry, for your own sanity :P
0
JohnDemerjianAuthor Commented:
cjrmail2k I am a tech in the windows world.  i have given up on my sanity a long time ago.  thanks for your help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cjrmail2kCommented:
LOL, no prob!
0
JohnDemerjianAuthor Commented:
None
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.