SharePoint Workflow email problem

The owner when going through the workflow can send emails, anybody else cannot - even if I give them full control.  I have the diagnostics logging turned up high for Workflow Infrastructure and I do nto see why this is happening.  I am lost when it comes to sharepoint.  Can you help me?
LVL 1
stowyoAmericas Regional IT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rafael ISolutions EngineerCommented:
By owner, do you mean the owner of the list?

With other people, do they finish the workflow successfully, or is it possible the workflow quits prematurely?  Try to set some variables in the process of going through the workflow to see if the workflow is working for everyone.

Is the email account that sharepoint is using standalone?  maybe its an account that only the owner has access to.  

Have you made sure that the SMTP server allows anonymous access and emails to be relayed?

I would start from the first question if you're more of a desktop user or from the bottom question if you are in charge of the server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stowyoAmericas Regional IT ManagerAuthor Commented:
Owner of the site.  We found the problem was the regional IT person there that had his groups setup wrong.  Once he wiped them out and repopulated, the problem went away.  

@rawsteak - I am going to give you the points for this as you had good stuff for me to check into (although they were already done).  The Exchange CAS Servers had a Connector setup to allow relay of this box - that is how the owner was able to send.  
0
stowyoAmericas Regional IT ManagerAuthor Commented:
Problem Resolved my myself mostly, but I wanted to give this other guy some credit for helping me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.