Apply master pages to subsites in SharePoint 2010 Foundation

:
I'm running SharePoint 2010 Foundation. On the Master Page Gallery | All Master Pages page, I see "The master pages in this gallery are available to this site and any sites underneath it." I don't see any way to apply those master pages to sites underneath this site, and all the instructions I see on the Web start with publishing the master page, which I can't do in SharePoint Foundation. So is MS lying to me?
JonFlemingAsked:
Who is Participating?
 
ImaCircularSawTechnical LeadCommented:
You might have to go onto the Central Admin site and nable the publishing feature there, then it's possible to activate it.  It's a little annoying I know, seems that the features on 2010 are a bit more granular than 2007.  You should be able to find it there though.

However, just re-reading your question, if it's foundation then you don't have the feature to enable.  Sorry I missed that one.  I suggest you look into way of doing it in SP designer.

I recommend you look into using this application:
    http://spfmasterpageselect.codeplex.com/
0
 
ImaCircularSawTechnical LeadCommented:
I don't have access to a machine right now but I understand what you're getting at. It's a bit of a hunt but you need to look for v4.master.  I would highly recommend you use sharepoint designer. With sp designer you can see a lot more folders than in the web interface and you can copy v4.master and edit it.

To set the master pages you'll need to go into the site settings for one of your sub sites.  Hope this helps!
0
 
JonFlemingAuthor Commented:
Oh, I've use SharePoint Designer to edit my v4.masters, but the question has to do with having one v4.master created on the main site and applying it to each subsite, rather than editing the v4.master for each subsite.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
ImaCircularSawTechnical LeadCommented:
OH, in that case, all you have to do is set each subsite to inherit masterpage:

http://technicallead.wordpress.com/2010/02/25/sharepoint-2010-cannot-find-link-to-master-page-page-layouts/

Once you've followed these instructions you'll be able to find the masterpage settings here:

Site Actions > Site Settings > Masterpage (under Look and Feel)

Tick the 'Inherit site masterpage from parent site' - this will probably need to be done on each subsite.

0
 
JonFlemingAuthor Commented:
Right now there's no "SharePoint Server Publishing Infrastructure" item in Site Collection features, so I can't activate it. However, my top-level site is pretty old, and this weekend I'm replacing it with a true SP 2010 site so that my bring it in ...
0
 
JonFlemingAuthor Commented:
Well that seems to be the solution. It's held on wheels to figure out how to install and access it, but I finally did.

For future people:

Download the WSP file to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN.

Open an elevated command prompt in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN and type:

[code]stsadm –o addsolution –filename IBS.SharePointFoundation.Utilities.wsp

stsadm –o deploysolution -immediate -allowgacdeployment –name IBS.SharePointFoundation.Utilities.wsp[/code]

After about five minutes, open your top-level site logged in as an administrative account. Site Actions | Site Settings | Site Collection Features and click the "Activate" button by "Master Page Picker" Now in Site Actions | Site Settings you will have a "Masgter Page Picker" item under "Look and Feel".

Lord help me, I actually remember some stsadm command strings.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.