How do I configure laptops to switch to the access point with the strongest signal in a wireless mesh?

My company manages a couple of small nursing homes. We are using Meraki access points to give the staff wireless coverage throughout the building. The problem we are having is that when a user takes a laptop from one end of the building to another the laptop will not connect to a new access point unless the signal from the original access point drops to zero.  In other words, it seems that the laptop does not know to look for access points with better signal as it passes through the building. Is there a way to set the laptops up to connect using a new access point if the signal strength of the old access point drops below a certain threshold? If not what are my options? Budget is a big concern so free or cheap alternatives are what we need.
itsupportdmgAsked:
Who is Participating?
 
residentsConnect With a Mentor Commented:
First off make sure you have the lastest wireless network card drivers for the laptops. Also check in the settings, depending on the network card you can choose to connect to the strongest signal. The easiest way to do this is to have all the access points on the same SSID and also have the channels staggered. You don't want all the access points on channel 11 etc. Can you be more specific, what wireless cards are you using, what operation system, have you staggered the channels on your access points but kept the SSID the same?
0
 
arrkerr1024Commented:
Ya, sounds like you have them all using different SSID (names).  You don't want this - you want them all to be named the same thing, and the logic in the driver will handle the switching.  They also, obviously, need to be set up exactly the same (same encryption key, etc) - although as the above commenter said, you'd ideally want to stagger channels so they don't interfere with each other.
0
 
itsupportdmgAuthor Commented:
Thanks for the quick responses guys! The SSIDs are all the same on the access points. I assume that the channels are staggered because I have the channel setting on the access points set to auto. I'll have to take a walk to verify if they are actually set to a different channel. We have a variety of laptops, but the one I have been using for testing is a Dell Latitude D610 and it uses an Intel Pro/Wireless 2200BG driver. I am using windows XP to manage my wireless networks. We also have some Windows 7 laptops at the facilities but we do not support anything further back than Win XP pro.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
itsupportdmgAuthor Commented:
I have verified that the Access points are spread over channels 1, 6, & 11. No access point is on the same channel as its nearest neighbors, but I am still having trouble with my laptops not letting go of their initial access point.
0
 
itsupportdmgAuthor Commented:
Well, despite my best efforts to find a software that I could install on all of the laptops that would allow me to set the roaming aggressiveness I am going to have to fall back and look at the drivers on each laptop to see if it has a roaming aggressiveness setting in the driver configuration. :(
0
 
itsupportdmgAuthor Commented:
The suggestion required additional research and did not point out that there was no universal solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.