Extremely slow access of VMware Fusion's shared folders

On my MacBook Pro, I use Snow Leopard with VMware Fusion 3.1.2 running Windows 7. The virtual machine freezes whenever I try to access shared folders located on the host machine.

I tried tweaking the virtual machine settings like using 2 processor cores, adding one more gigabyte to RAM (up from 1024 MB to 2048 MB), and disabling 3D graphics, to no avail.

I tried modifying Performance Options in Windows 7 like disabling Aero and animations, also to no avail.

Help!
Anton TajanlangitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

larry urbanDevOps EngineerCommented:
Hi AntonTai,

Try uninstalling VMware Tools completely and reinstalling VMware Tools. It should then be working ok.
0
larry urbanDevOps EngineerCommented:
In addition, if that does not work you can try:

This behavior can occur if there is an incorrect setting in the following registry entry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common Administrative Tools

You may try the below steps to make changes in the registry and get rid of the error.

   1. Click Start, type regedit, in the start search box and press enter.
   2. Locate and then click the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

   1. In the right pane of Registry Editor, double-click Common Administrative Tools.
   2. In the Value data box , type the following line, and then click OK:

%ALLUSERSPROFILE%\Start Menu\Programs\Administrative Tools

   1. On the File menu, click Exit to quit Registry Editor.
   2. Restart the computer.
0
Anton TajanlangitAuthor Commented:
Hi Todar. There is no "Common Administrative Tools" in the right pane. There are such other things as Common AppData, Common Desktop, Common Documents, etc.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Anton TajanlangitAuthor Commented:
Ah, I discovered that "Common Administrative Tools" is to the right of "Shell Folders" and not "User Shell Folders."
0
Anton TajanlangitAuthor Commented:
Done your instructions to the letter and restarted the computer. Still the same problem.

I already did the uninstall and reinstall of VMware Fusion even before I posted my question.
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Keep in mind the following:
-all the Mac OS IO as well as the Fusion IO is running on your single drive in your Mac
- your Fusion guest OS is just a large file on your Mac internal HDD.

Those things combined with the amount of activity on your Win7 OS can slow your Mac down.

My recommendation is to config Fusion to share your Mac's ~/Documents folder for your Win7 OS "My Documents" folder.

By doing this, you won't have to access a virtual network share for data access on your Win7 machine.

HTH...
0
Anton TajanlangitAuthor Commented:
How do I do this?
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I'm not in front of my Mac right now so it escapes me which menu it's under. Check your unity settings in VMWare Fusion.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anton TajanlangitAuthor Commented:
Thanks nappy_d, problem solved! From the virtual machine settings, under Sharing, I just added the subfolder from the host machine that I wanted to access from Windows 7. Everything's snappy now!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.