Service dependencies giving interface: class not registered error

Hi we have Windows Server 2003 standard edition. If i go look at dependencies of any services is administrative tools. It comes up with an error that says. "Interface: Class not registered". This happens to all the services. any ideas why this could be happening?
TSKC-IncAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FireW0lfCommented:
Hi

You just need to repair WMI, since it's WMI that the Dependencies tab uses

Start / Run, cmd
rundll32 wbemupgd, RepairWMISetup

Open in new window

TSKC-IncAuthor Commented:
it gives me an error that says "Error in Wbemupgd Missing entry:repair WMI setup"
FireW0lfCommented:
Did you type it exactly as I put it? Ther are no spaces in "RepairWMISetup"
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

TSKC-IncAuthor Commented:
yes I did type it without any spaces.
FireW0lfCommented:
Hmmm so it may be that you need to re register the dll files and exe's

Open a cmd prompt and enter the following 3 commands
cd /d %windir%\system32\wbem
for %x in (*.dll) do RegSvr32 -s %x
for %x in (*.exe) do %x /RegServer

Open in new window


Once you've done that, check your Dependencies tab, and if it's still not showing correctly, then rerun the
rundll32 wbemupgd, RepairWMISetup

Open in new window

line

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TSKC-IncAuthor Commented:
Thanks for that but I'm getting an error message. I'm attaching an image.
ee.JPG
FireW0lfCommented:
Thats fine - what you did was try to re-register all dll's and all exe's

Not all file though have an option to register themselves - they're just stand alone exe's - you can ignore the error lines. As you can see the first 6 registered fine

After you did that, and ran the rundll32 line again, can you now see your Dependencies?
TSKC-IncAuthor Commented:
i did run rundll32 line but I still get the same error message when trying to view the dependencies. Thanks for reply back. should I reboot?
TSKC-IncAuthor Commented:
Did not resolve issue
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.