64bit VirtualBox guest stopped working

The host machine is Ubuntu 10.04 64bit and the guest Windows XP 64bit, everything was working until recently and I'm not sure what changed to make it stop. After it stopped functioning I tried upgrading to 4.0.4 from 3.2 but it still does not get past a screen that says

Windows could not start because of a personal computer hardware configuration problem.
Attempting to load an x64 operating system, however this CPU is not compatible with x64 mode.
Please install an i386 32-bit operating system.

But uname on the host outputs:
Linux vm2 2.6.32-30-server #59-Ubuntu SMP Tue Mar 1 22:46:09 UTC 2011 x86_64 GNU/Linux

The settings for the guest are:
System
  /Motherboard
    chipset PIIX3
    enable IO APIC
  /Acceleration
    enable VT-x/AMD-V
    enable nested paging

and essentially the defaults for the rest.

I'm not even sure where to look at this point so any help would be appreciated. Thanks.
LVL 3
coandaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
Check your BIOS setting to make sure VT-x/AMD-V is enabled. Sometimes the BIOS upgrade will disable VT-x.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wesly_chenCommented:
In addition, for 64-bit Windows guests, you should make sure that the VM uses the Intel networking device, since there is no 64-bit driver support for the AMD PCNet card.

Check this:
http://www.virtualbox.org/manual/ch03.html#intro-64bitguests
0
coandaAuthor Commented:
No change was made to the BIOS between the time that the virtual machine was working to when it stopped working.

I'll have a look tomorrow but I'm almost positive that the adapter is set as the PRO/1000 MT desktop adapter.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

gtkfreakCommented:
Try without network adapter. I did this once to make it work http://www.askmeaboutlinux.com/?p=876
0
coandaAuthor Commented:
Disabling the network adapter did not work, neither did changing it to one of the other options. I decided to update the BIOS using the update directly from the Asus website and to my dismay doing so has caused a kernel panic that prevents startup, I can't even revert back because the new BIOS doesn't have the tool to flash anymore. Yippee. I will have to deal with this at some point but for at least until next week I'm going to have to put this on hold.
0
coandaAuthor Commented:
I finally got around to fixing my problem with the BIOS. I enabled the virtualization options and tried the virtual machine again but have the same problems as before.
0
wesly_chenCommented:
Disable nested paging on guest machine...

That's an issue with Virtualbox 4.0.x.
http://forums.virtualbox.org/viewtopic.php?f=3&t=38120
0
coandaAuthor Commented:
I never was able to get it to work on the server it was on so I created an OVF of it and imported it into a new 64bit server and it worked.

Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.