Red Hat Linux 5 FreeFontPath: FPE "unix/:7100" refcount is 2;should be 1;fixing

I'm unable to launch STARTX.

I'm getting the following error messages in the logs.

(**) RADEON(0): RADEONSaveScreen(2)
(**) RADEON(0): RADEONCloseScreen
(**) RADEON(0): RADEONDRIStop
(**) RADEON(0): RADEONDisplayPowerManagementSet(0,0x0)
(**) RADEON(0): RADEONRestore
(**) RADEON(0): RADEONRestoreMode()
(**) RADEON(0): RADEONRestoreMemMapRegisters() :
(**) RADEON(0):   MC_FB_LOCATION   : 0xffff0000
(**) RADEON(0):   MC_AGP_LOCATION  : 0x003fffc0
(**) RADEON(0):   Map Changed ! Applying ...
(**) RADEON(0):   Map applied, resetting engine ...
(**) RADEON(0): Updating display base addresses...
(**) RADEON(0): Memory map updated.
(**) RADEON(0): Programming CRTC1, offset: 0x00000000
(**) RADEON(0): Wrote: 0x0000000c 0x00070047 0x00000000 (0x0000a500)
(**) RADEON(0): Wrote: rd=12, fd=71, pd=7
(**) RADEON(0): Disposing accel...
(**) RADEON(0): Disposing cusor info
(**) RADEON(0): Disposing DGA
(**) RADEON(0): Unmapping memory
FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.
FlorescuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wesly_chenCommented:
as root,
yum install xorg-x11-fonts*
0
FlorescuAuthor Commented:
I tried that already, same thing.
0
wesly_chenCommented:
check this:
http://www.mail-archive.com/centos@centos.org/msg35018.html

Basically make sure ~/.Xclients-default  is not empty. Here is the sample one:
---------
#! /bin/bash
# Created by Red Hat Desktop Switcher

WM="startkde"
WMPATH="/usr/bin /opt/bin /usr/local/bin /usr/X11R6/bin"

for p in $WMPATH ; do
        [ -x $p/$WM ] && exec $p/$WM
done

exit 1

0
FlorescuAuthor Commented:
I also tried the following:

yum install cairo

edit  /boot/grub/grub.conf
as(add selinux=0)
title Red Hat Enterprise Linux Server (2.6.18-194.el5)
 root (hd0,2)
 kernel /vmlinuz-2.6.18-194.el5 ro root=/dev/VolGroup_ID_1007/LogVol1 rhgb quiet selinux=0
 initrd /initrd-2.6.18-194.el5.img


run the following command on your system to install all the required packages for Gnome Desktop.
$ yum groupinstall "GNOME Desktop Environment"

Please refer, https://access.redhat.com/kb/docs/DOC-37287
---------------------------------------------------

I also got the following error message when I tried to boot with runlevel 5:

(i.e. edit /etc/inittab)

Init 3 (networking without Gnome)
Init 5 (gnome)

Your session only lasted less than 10 seconds.  if you have not logged out yourself, this could mean that there is some installation problem or that you may be out of diskspace.  try logging in with one of thefailsafe sessions to see if you can fix this problem.View details (~/.xession-errors file)


----------------------------------------------------------
FIX:

deleted etc/X11/xorg.*    
also del backup xorg file

I tried Startx again, got an error message about a lock file:

deleted lock file under /tmp

launched Startx again

-->this seems to have fixed it


Note: You also have to make sure you're in the right terminal:

i.e. CTRL ALT F7 (terminal with GNOME)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FlorescuAuthor Commented:
found solution elsewhere
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.