sga size

I was trying to increase the size of sga size..
it ended up in error..
here is what I did..
SQL> show parameter sga_max_size;

NAME                                 TYPE        VALUE                          
------------------------------------ ----------- ------------------------------
sga_max_size                         big integer 512M                          
SQL> alter system set sga_max_size=520M;
alter system set sga_max_size=520M
                 *
ERROR at line 1:
ORA-02095: specified initialization parameter cannot be modified
nobleitAsked:
Who is Participating?
 
johanntagleCommented:
From your pfile:
*.sga_max_size=512
*.sga_target=226492416

try *.sga_max_size=512000000
0
 
johanntagleCommented:
Hi.  What Oracle version?  Anyway you need to do add scope=spfile and restart the instance.

For 11g, you should check and modify the memory_target and memory_max_target parameters.  For 10g, it's the sga_target and sga_target_max parameters.
0
 
nobleitAuthor Commented:
please...
I did like this...
alter system set sga_max_size=520 scope=spfile;
system altered
shutdown

conn / as sysdba
connected to an idle instance

startup mount
ora-00823:specified value of sga target greater than sga_max_size

how can I solve this issue...
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
johanntagleCommented:
oh you missed the M in sga_max_size.

shutdown the database
SQL> create pfile='/path/to/init.ora' from spfile;

edit the generated file to correct the sga_max_size parameter.

SQL> startup pfile='/path/to/init.ora'

0
 
nobleitAuthor Commented:

we know sga_max_size was 512M before..(create pfile file from spfile was successfully created)
so edited initorcl.ora   ok
ans saved..
but
when I did
SQL> startup pfile='C:\app\Mathew\product\11.1.0\db_2\database\INITorcl.ora';
ORA-00823: Specified value of sga_target greater than sga_max_size
ORA-01078: failure in processing system parameters

again problems
what could be the problem..
this is the copy of the edited initorcl.ora

orcl.__db_cache_size=247463936
orcl.__java_pool_size=12582912
orcl.__large_pool_size=4194304
orcl.__oracle_base='C:\app\Mathew'#ORACLE_BASE set from environment
orcl.__pga_aggregate_target=268435456
orcl.__sga_target=536870912
orcl.__shared_io_pool_size=0
orcl.__shared_pool_size=264241152
orcl.__streams_pool_size=0
*.audit_file_dest='C:\app\Mathew\admin\orcl\adump'
*.audit_trail='db'
*.compatible='11.1.0.0.0'
*.control_files='C:\app\Mathew\oradata\orcl\control01.ctl','C:\app\Mathew\oradata\orcl\control02.ctl','C:\app\Mathew\oradata\orcl\control03.ctl'
*.db_block_size=8192
*.db_domain=''
*.db_name='orcl'
*.db_recovery_file_dest='C:\app\Mathew\flash_recovery_area'
*.db_recovery_file_dest_size=2147483648
*.diagnostic_dest='C:\app\Mathew'
*.dispatchers='(PROTOCOL=TCP) (SERVICE=orclXDB)'
*.memory_target=803209216
*.open_cursors=300
*.processes=150
*.remote_login_passwordfile='EXCLUSIVE'
*.sga_max_size=512
*.sga_target=226492416
*.undo_tablespace='UNDOTBS1'
0
 
nobleitAuthor Commented:
working file thanks a lot
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.