SBS 2003. After a change of user logon and email when sending emails from Outlook 2003 the old email address is used

On a SBS 2003, I changed a user logon and email as explained in the following http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22744744.html.

I had to rebuild GAL and recreate the outlook profile to have the correct name of the user in Outlook.

Problem : when the user try to send an email, the from address is still the old email address, the user can change manually the from address with its new address and send the mail normally.

I made the change 4 day before, so I don't think Exchange is that slow to make the change.

Any idea ?

Thanks

PS: I don't have remote access to the server, and will be tomorrow on site, so without solution I will create a new user with correct information and delete the old one
jpgeorgeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

naomelixesCTOCommented:
Did you uncheck the option to automatically update e-mail addresses based on recipent policy?
In Server Management -> Users, right-click the user and go to Properties -> E-mail Addresses.
Click the desired address and click "Set As Primary". Uncheck the option "Automatically  update e-mail addresses based on recipent policy".
Should work fine now.
0
jpgeorgeAuthor Commented:
Sorry for being so late to answer and thanks for your help.

No, I hadn't uncheck the option to "Automatically update e-mail ...", but I tried to unchecked it and it still doen't work.

Any other idea ?
0
naomelixesCTOCommented:
After unchecking that option, did you re-set the primary address? The only SMTP address in bold has to be the one you want to be shown in the From: field.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

jpgeorgeAuthor Commented:
Yes, I even try to set another as primary and reset the good one as primary after (which is in bold now).

But still doesn't work.
0
naomelixesCTOCommented:
Very strange. Restart your Exchange System Attendant service, please. It will restart a bunch of services associated with it.
After it is restarted, try again.
0
jpgeorgeAuthor Commented:
Thanks, I will try it.
0
jpgeorgeAuthor Commented:
Sorry for the delay.

No, the restart of the server doesn't change anything, it still doesn't work.
0
jpgeorgeAuthor Commented:
Just discovered that the user has an outlook addin which fills the from address with her old email address. Uninstalling the addin solves the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jpgeorgeAuthor Commented:
it is the solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.