Remoting in with Virtual XP Windows on the Mac

In order to remotely log in to our windows environment at work, a new agent bought "Parallel for Macs," which gave him a home edition Windows XP environment on his Mac laptop.  However, when he tries to remote in, he gets the error, "An invalid server name was specified."  The agent didn't ask me ahead of time and I have no experience with Macs, so appreciate any suggestions.  Did he even by the right sw?  We're on Small Business Server 2003 and remote in using Remote Web Workplace.
LVL 2
rvfowler2Asked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You could use RDP built into WIndows and available for Mac, which will allow you to connbect to your Windows Servers via "Remote In".
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
strungCommented:
As long as she can connect to the internet using IE on Parallels, it should work exactly the same as on a PC. Just troubleshoot it as if it were a PC>
0
 
strungCommented:
You said in your initial post, "if i unplugged it for a extended period of time the mac will boot up no problems". I had assumed that meant that it would boot normally and the backlight would light. If that is the case, the backlight is not the problem.

The more likely problem is either you need the SMU re-set as above, or the clock battery replaced.
0
 
rvfowler2Author Commented:
The agent installed Parallels without my help.  I'm not sure how this sw works, but he doesn't doubleclick on a parallel icon to go into a virtual Windows environment, but goes into a "Windows XP Applications" folder and opens IE.  This seems to be opening IE within the Mac environment, but am I wrong?  

Anyway, when we go to our website and click on "Remote Web Workplace" and then click on "Connect to Client Computer", we get the exact same error as when we try to connect within Safari in the Mac environment:  "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control..."  Being the same error, I'm wondering if we are still within the Mac environment, though we are clicking on IE.  Nevertheless, I still used IE to search for the Remote Web Active X control and downloaded it, but this did not change the error.  Any suggestions?  Thanks.
0
 
strungCommented:
It should be easy to tell whether he is using IE within the Mac environment.  Just go to the Help menu and see which version of IE is being used. The newest Mac version was, I believe, 5.2.3. If the version is anything newer than that, he is using it in the Windows environment.

If he wants to be sure, tell him to switch from "coherence mode" to "window mode".

In coherence mode, Windows apps appear to run directly in the Mac OS and this can be confusing as to whether you are using Windows or Mac programs. In "Window Mode" you will see a Windows desktop inside a Mac window and all Windows apps will run inside that window, making it clear whether you are using a Windows or Mac app. Also when you download ActiveX using IE for Windows, you can download it to the Windows desktop and install it from there to make sure it is being installed correctly.
0
 
rvfowler2Author Commented:
Where do you go to run coherence mode.  Do you click on a Parallel icon?
0
 
rvfowler2Author Commented:
In Help, it said IE 8.0, so it seems to be the windows version.
0
 
rvfowler2Author Commented:
And he has a Parallel Desktop 6 icon, but when I 2click on it, it only has 3 options:  Install, Getting Started, or Uninstall, obviously none of which run the program.
0
 
strungCommented:
Pressing Shift+Control+Alt should switch from coherence mode to Windows mode.
0
 
rvfowler2Author Commented:
Shf, Control, Alt didn't work.  The website only tells me what to do after I've initiated Parallel.  I need to know how to open parallel.  I'll look online while I'm waiting for your answer.
0
 
rvfowler2Author Commented:
Finally found a manual, downloaded it, went into the Parallel sw, changed it to window mode to be absolutely sure we were in Windows, but am having the same problem as above.   "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control..."  When this message came up on the prior 20 Windows laptops I configured successfully, there would always be a bar across the top that would allow you to download Remote ActiveX.  So, I went to a website and downloaded that way anyway, but am still getting the error.  Then, tried lowering all the security settings, but when I do that, then we're back to his original error of, "An invalid server name was specified."  Any suggestions from here?  What's different about Win on the Mac that won't allow me to run ActiveX in virtual Windows?
0
 
strungCommented:
There should be no difference. When you are in Parallels, you are running Windows. The problem is a Windows setting somewhere, or the wrong version of  IE.
0
 
strungCommented:
Google "RWW and IE 8". There are all sorts of comments about problems running RWW with IE8
0
 
rvfowler2Author Commented:
Thanks, went to the website and tried each suggestion with no change:
1. Turned off the smartscreen filter.
2. Played with compatability view (off and on, etc.)
3. Booted IE without add-ons

Interesting that when I booted up without add-ons, I did receive a bar across the top telling me to click on it if I want to manage add-ons.  This is the same bar, I expect to download ActiveX; however, I've gone to the site and manually downloaded and installed it twice now with no change.  Though there should be no difference, there is.  As I've said, I've been able to set up over 20 people with remote connection with very little problem.  Seems like Macs are a bit more difficult than advertised.  :)
0
 
strungCommented:
I am almost 100% sure the problem is not a Mac problem, but a Windows problem. Can you revert to IE 7?
0
 
strungCommented:
You might check the Windows firewall settings. I know that VMWare comes with McAfee by default. Don't know what Parallels comes with.

As I say, if you treat it as a Windows problem, you should be able to solve it.
0
 
rvfowler2Author Commented:
He has no antivirus installed.  Turned off Windows firewall for a moment and tried and still the same problem.  I have IE8 on just about every remote computer that access our RWW and they have no problem, so not sure reverting to IE7 will help.
0
 
rvfowler2Author Commented:
Genius.  The last suggestion worked.  Thanks so much.
0
 
strungCommented:
Glad to help. As I said, not a Mac problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.