RDS 2008 R2 - RDS Gateway external "the logon attempt failed" error

I have a strange, inconsistent problem. Two servers, both Server 2008 R2 SP1. First server is web-facing with the RDS Gateway, Web Access, and Session Broker roles installed along with Exchange 2010 and all associated roles. Second server is just RDS Session Host.

Internally, everything works fine. RD Web Access, remoting directly into both the web access server and the session host.

Externally, it works about 50% of the time. I can always login to the Web Access portal but when I launch an app, it constantly says that "the logon attempt failed" after entering my user/pass. I can't find any errors logged anywhere about this on either server. In the event that it doesn't work, I have to reboot RDS services and machines until it finally starts working but I have not found a surefire way of fixing it. I have tried changing the configuration in the Web Access portal from going directly to the session host to a farm to using the connection broker. Because it works internally, I think that it's an issue with the Gateway server, not my Session Host.

I should also add that I have a nearly-identical setup for another client that is working perfectly. The big difference is that my gateway server also has Exchange services running on it.

Thoughts?
LVL 1
helpmepcsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

helpmepcsAuthor Commented:
Fixed this myself. A coworker asked if it was working and said, "I have Outlook Anywhere setup on my laptop but I want to try your RDS setup," and it occurred to me that the login process must use RPC over HTTPS. I asked him to test his Outlook Anywhere and, as I theorized, it didn't work either. I checked my IIS config and sure enough, Windows Authentication was disabled on the RPC container. Enabled, IISRESET, and my remote apps immediately worked. This can be closed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.