Website won't work without WWW

Hey all, having an issue here and I hope you can help. I'm running a web and exchange server. Both running Microsoft Windows Server 2003. I recently had an issue reported to me. Apparently our website wasn't working without the www in front of it. So(on exchange server), I went into the MMC(start-run-MMC) and added the DNS snapin. I have two domain controllers and exchange is one of them.  I expanded Forward Lookup Zones and selected my domain. I myself didn't create this network originally, but I manage it now. I noticed that there were several Host (A) entries for the (same as parent folder) entry which from my understanding indicates the forwarding path of the domain without a prefix, IE www.

So, I made note of those forwarding paths and their settings, backed them up, and removed them, leaving only one forwarding path, to the public IP for the actual website. I tested this and it didn't work instantly, but strangely enough it worked after about 15 minutes, despite the fact that I cleared the IE cache on the computer I was trying to use.

All was well and good until today when the same issue popped back up. I went back into the DNS snapin and discovered some of those forwarding paths had been readded. I'm assuming they replicated from my other domain controller? I'm not sure what the deal is. I deleted them again, and once again after 15 minutes I was able to follow my non-prefixed domain back to my actual webpage.

Also, I haven't tried this webpage externally today. I'm trying it from my network. I'm pretty new to website development and management in general, and I didn't know what the folders DomainDnsZones and ForestDnsZones indicated. Is it possible some of the entries are replicating from these folders, or perhaps the replication is in my mind, and inner network forwarding zones are simply different than the DNS Host (A) type entries entered under the standard domain. One more note, I use the same domain to manage an intranet and a web-based outlook email system via exchange, with different prefixes.

Basically, I'm fixing this, but it won't stay fixed. Sorry about the convoluted explination, incorrect assumptions, and exceedingly poor grammar, any thoughts?
JoshBPAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

meko72Commented:
To set up a record on your domain for the root, e.g. myweb.com (not
the www bit), you use the @ sign in the zone file, e.g. you might have;

www   A    your IP address
@        A    another IP address

0
it_saigeDeveloperCommented:
DomainDnsZones and ForestDnsZones are specific to AD and should not contain any records other than those associated with the Domain Controllers.

Did you check both DNS servers and ensure that the records are removed from both?  Also, are you DNS Zones set to replicate to (All DNS Servers, All Active Directory Servers or just the servers below)?  Are your DNS Zones setup as AD Replicated and therefore only allowed to use secure updates?

-saige-
0
GundogTrainerCommented:
OK,
the client PC will cache DNS name resolution not internet explorer so you may want to try:
ipconfig /flushdns
so you can check whats happening.
Also you may want to check what servers are the authoritative nameservers for your domain - you may be clearing them internaly but if they are not authoritative they will update from the master. This may well be hosted externaly by your ISP.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

StefanLambdaCommented:
I think you should check the DNS record of the web site :
   go on http://centralops.net/co/NsLookup.aspx 
   select query 'A IPV4'
   try the both adress :  www.yoursite.net  & yoursite.net
  It should return the same IP

Check the "http header" on your website (IIS) : you should have a record for the both adress www.yoursite.net  & yoursite.net.

Stefan




0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JoshBPAuthor Commented:
Ok tried a few things out as per suggestions.
1.  I tried using the @ symbol to create a new A Host file. It said that @ was an invalid character.
2. I attempted to remove the records from both of my Domain Controllers. However, recently we installed a new domain controller and repurposed the old one. The old DC has the DNS snap-in on it and it is properly configured. However, we did switch IP addresses also when we replaced the old DC. That being the case, I attempted to remove the documents from all three servers. The two older servers were fine.(after which I attempted to see if the website would immediately comeup after the dns flush command, which it did not as it still took a few minutes). However, the new DC doesn' not have the DNS snapin installed(blah!) and I don't think dns was ever configured there anyway unless it replicated automatically which it probably did.
3. I didn't immediately see the path to check my dns replication settings. What is that path?
4. While we're at it, how can I check to see my domain's authorative name servers?
5. I went to http://centralops.net/co/NsLookup.aspx and entered both addresses. This was AFTER I recleared the documents. The IP addresses were the same, though the address without www lists some ISP info as well.
6. I checked my http header on my web sever iss. There was an entry "X-Powered-By:ASP.NET". I'm assuming this is a code related function so I left it. There were no other entries. I've never configured a http header before so I took a shot in the dark:
Custom header name: mywebsite.com
Custom header value: http://www.mywebsite.com/

So...grrr! It's working now, but for how long? I'll update if it sticks or doesn't.
0
StefanLambdaCommented:
Please find an IIS config for website working with and without "www".
NB: the IP is the private IP, the public IP is translated to the private IP in the NAT (I am not so sure )
Is it ok for you?
 IIS config
0
JoshBPAuthor Commented:
Stayed fixed. As for the final suggestion; that is not configured correctly on my system but I'm not going to mess with it. Everything is working fine right now.

The likely fix was deleting the documents on both domain controllers around the same instant to avoid replication, OR by adding the appropriate http header. I'm not sure which fixed my issue because I tried them both at once.

Thanks all.
0
JoshBPAuthor Commented:
Final update. I discovered that my DomainDNSZones and my ForestDNSZones' partition (found in folders under the DNS Snapin on each domain controller) were also populated by the documents in question, and from those respective folders were replicating their contents back into the DNS domain folder. After proper backup(of course) I removed these documents from the ForestDNSZones folder and the DomainDNSZones and they have not replicated since. Website up and running. I believe this is only an issue that one would experience if their dns zones are fully integrated with AD.

Thanks all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.