WRT54g2 v1 and V1.5 not allowing VPN pass through (router on client end)

I have (at HQ) a Windows 2008 box with RRAS set for VPN access.  The firewall is configured to port forward 1723 to the server. Incoming connection is a T1.  

At my local test site/connection I have been able to get a VPN connection using the XP VPN client through a 2-wire DSL modem/router successfully. The problem is on the client end with a linksys wrt54g2 router.  The client sites have static IP via SMC modem and WRT54g2 routers and the VPN will not stay connected for more than 20 seconds and no routing occurs.  I have confirm this being an issue as I put in place a wrt54g2 router (between my xp box and dsl modem) at my test site and it fails then also.  The common variable is the linksys wrt54g router.  I have seen many posts about vpn issues with the wrt54g models but no clear resolution, other than replacing the linksys router. I am trying to avoid that as we have more than 20 sites using this router.  I have verified that VPN pass-through is enabled on the linksys and wireless is currently disabled.  Both 2-wire and linksys modems are using different IP addressing than the w8k server therefore I know it is not an IP conflict (besides, remember it works with just the 2-wire modem).  I have tried changed the MTU settings on the wrt54g2 to 1400 and 1300 and not improvement.  I had also disabled QOS on the NIC on the xp box, not help. On the XP box for the VPN connection, set to PPTP manually and unchecked options for "enable LCP connections", "Enable software compression" and "negotiate multi-link for single link connections", no improvement. Everything points back to the wrt54g2 as the issue.

Doesn't work:
(real site) W8K <-> HQ firewall <-> internet <-> client site modem <-> wrt54g router <-> xp
or
(test site) W8K <-> HQ firewall <-> internet <-> test site 2-wire dsl modem/router <-> wrt54g2 router <-> xp

Works: (notice no wrt54g2)
W8K <-> HQ firewall <-> internet <-> remote site 2-wire dsl modem/router <-> xp

We cannot change anything at the HQ end.
Flashing the routers with different firmware is not an option as some of them don't support it (to little internal memory).

Any suggestions (other than replacing the WRT54G2)?  Is there some other special configuration, consideration or setting on the wrt54g that I am not seeing.  
LVL 1
PlazaPropAsked:
Who is Participating?
 
AnakiManaCommented:
If you can verify that the original firmware is at fault, you probably HAVE to replace the routers, or at least the v1.5 units since they can't be flashed to DD-WRT.

I would flash one of your v1.0 units to DD-WRT and run another test.  If it also fails, check your modem settings and be sure uPNP is enabled and any VPN passthrough or firewall in the modem is configured properly.

If price is an issue, Newegg.com sells a good DD-WRT capable wireless router (which guarantees you'll get it working, either through scripts or the GUI, with lots of support available) for as little as $27.

http://www.newegg.com/Product/Product.aspx?Item=N82E16833166032

~Andy
0
 
zazagorCommented:
Hi,

Try to open the 500 and 4500 UDP ports from HQ to the WRT54G.
Also add the ports in XP if you have the firewall active.
I kow ... you don't need to add the ports in the case when you use "2-wire dsl modem/router ",
but that's a different hardware and it maybe uses the ports differently.

//zaZagor
0
 
PlazaPropAuthor Commented:
It is definitely a linksys firmware issue.  I was able to put in a w54gl with dd-wrt on it and the vpn worked ok.  

zazagor:  not sure exactly what you are getting at but I tried to utilize the port triggering but that didn't work.  

I have even put the test xp box in the DMZ zone and it sitll didn't work.  
0
 
PlazaPropAuthor Commented:
Confirmed that it is the firmware on the wrt54g2.  I flashed a test wrt54g2 unit with dd-wrt and my vpn connection work just fine.  Guess I will have to look at either flashing as many as I can or just purchase new (non-cisco/linksys) routers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.