Remote Desktop redraw is painfully slow?

When I run a remote desktop session to my work computer, the redraw rate is very slow.  Specifically, when I type text into a window, the area around the text flickers for about 10 seconds after I type, slowly adding letters.  I get the same lag effect when I scroll up/down in a window.  Strangely enough, I only notice the redraw rate within specific applications (like Visual Studio).

However, when I connect to my work computer over remote desktop from my laptop (another pc on the same network as my home computer), it works great.  So it's definitely an issue on my home computer.

The only things I've changed that I know of since the last time it worked good (a few weeks ago are)

- Installed a new video card (nVidia geforce 8400 GS, with current drivers)
- Made my logon account a restricted user.

Home Computer running XP Pro
Home Laptop running Vista
Work Computer running Windows 7 Ultimate

Any suggestions are most appreciated!
Thanks
LVL 33
raterusAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jaustin1Commented:
Sure sounds like a vid driver thing to me.  Maybe try the newly released Nvidia beta drivers, or try going back a driver version?
0
jaustin1Commented:
Also make sure to disable stuff like "Desktop background" on the RDP Experience tab in options.
0
raterusAuthor Commented:
Thanks for the suggestions, unfortunately I'll have to wait until I'm actually home to test them out.  I will definitely try to vary the drivers, wouldn't be the first time I've had nvidia driver issues!

I know I've already modified the experience like it was over a modem connection, so that is not the issue.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

raterusAuthor Commented:
Sorry for the delay in responding.

As it turns it, it has something to do with my profile on the client computer.  I tried to remote desktop from another user account, same computer, and it works great.  That rules out anything we have been talking about up until now.

Like I said, I set my "experience" on the modem selection, and beyond that, I can't think of anything else to try.
0
raterusAuthor Commented:
I think I figured it out.  It has to do with the color depth selection in remote desktop.  My home computer runs in 32-bit color, but my remote desktop was set to 16-bit.  Once I matched the color depth, the issue went away, that is I set 32-bit color on my remote desktop session, which matched the 32-bit selection on my local computer.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jaustin1Commented:
Good catch!
0
ModCorlEEoneCommented:
raterus,
 
I am starting the self-close process on this question because it appears to me that the Expert(s) answered your question.
 
ModCorlEEone
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.