Password request when opening Office docs on Windows 7

I am upgrading my computers to Windows 7 Pro x64 and have found a strange problem.

I have Sharepoint 2 on a Windows 2003 server which is basicly running the companyweb off of a replaced SBS. (before I was here.) When users that only have read access on the Sharepoint server try to open Office docs they are asked for a username and password. If they hit cancel the document opens but I have some hyperlinks in the excel spreadsheet that point to another spreadsheet on the companyweb which will fail and tell them the file could not be opened. If I give them edit access to the companyweb they work fine. These are files that they can't have edit access to.

My remaining XP system do not have this problem.
bradoconnor75Asked:
Who is Participating?
 
bradoconnor75Connect With a Mentor Author Commented:
This is how I have it working for now. (I still don't consider this the fix but it is working) I setup Excel and Word in compatibility mode for XP sp3. Then to fix my hyperlinks, I found that if they started with file:/// they didn’t work but if I pointed to the documents as a URL (http://) then it would open. This has made it work but I still feel like this is a Band-Aid  fix and not a real one.
0
 
GeorgeGerguesCommented:
Few  questions

Version of Office on both machines.
Version of Internet explorer on both machine.
Is your company site something like  http://Server or http://Server.Domain.AnotherDomain....
0
 
jaustin1Commented:
Make sure that the Sharepoint site is added to the Trusted Sites list in Internet Explorer on the problem machines (Tools, Internet Options, Security tab).  If that's not enough, try setting security on Trusted Sites (same tab) to Low.

I had to do this in order for it to retain the username/password and make it so they didn't have to login every time.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
bradoconnor75Author Commented:
They both have Office 2007 and IE 8.

It is http://companyweb
0
 
bradoconnor75Author Commented:
I tried that. I only get the password prompt when I open an office document. all other docs open fine. If I add the edit right to the reader group then it works fine.
0
 
jaustin1Commented:
0
 
bradoconnor75Author Commented:
I saw that. I don't have a proxy server and I don't want to run the office products in compatibality mode. There is also another article that talks about this hotfix and says you only have to edit the registry in Win 7 to allow the credentials to pass through. Which I tried. I don't think the problem is the credentials being passed through but that for some reason win 7 is needing edit rights in the document library.
0
 
jaustin1Commented:
Well, shoot.  I knew this was a familiar issue, so I rooted through our own internal help desk and found almost this exact problem.  We fixed it by upgrading the user to Office 2010. :(
0
 
bradoconnor75Author Commented:
Just to see if it made a difference, I tried changing excel to run in xp mode and it does work like that.
0
 
bradoconnor75Author Commented:
LOL that sounds like something a Microsoft sales person would tell me how to fix this. :)
0
 
jaustin1Commented:
Heh.  Yeah, we're an MS Partner so had a free license.  It ain't a cheap fix otherwise. :(

0
 
GeorgeGerguesCommented:
I think your documents are activating the document information panel
you may want that to be optional
Open word ,   Word Options -> Advanced - >   - >Service Options ->  un check the options to open the docuemtn informatin panel

It is somewhere here .


I don't recall exactly what it it , but the DLL name Author.dll actually contacts the server when you initiate the communication with Server to get other information related to your document.

if that DLL is disabled by your antivirus , that may casue such behavior .


Best of luck

0
 
bradoconnor75Author Commented:
That option is not checked in Word. And I don't have an AV on this system yet.
0
 
bradoconnor75Author Commented:
I was wrong about running in xp mode working. It does open the first spreadsheet without asking for a password but when I click on the hyperlink to another spreadsheet in the first one I still get the error that I can't open the document.
0
 
GeorgeGerguesCommented:
Can you do the same test on the server itself .

also can you do the test using a firefox browser and compare the difference in behavior ?
0
 
GeorgeGerguesCommented:
I also wanted to see if you can get to the application log on the web server to see if the application pool reacts differently.

0
 
bradoconnor75Author Commented:
If I do it from the server logged in as administrator it works fine but it also works fine if I give edit rights to whoever is trying it. When I put FireFox on the system it asked for the username and password as soon as I went to the companyweb. It still would not open the link inside of the spreadsheet.
0
 
bradoconnor75Author Commented:
Also I don't get any errors in the logs on the server or the machine.
0
 
GeorgeGerguesCommented:
are you sure you don't have a second hop somewhere like a firewall or a ISA.

from the client can you ping by name

does the IP match the IP on the NIC at the web server ?
0
 
bradoconnor75Author Commented:
There is no hop between the machine and the server. I tried a tracert just to make sure. i also piged the server using companyweb and it worked fine. The only change is the system now has windows 7. The systems that are still running XP don't have this problem.
0
 
GeorgeGerguesCommented:
OK ,
some more questions :

1- Do these documents have required fields ?
2- Are they in a version controlled library ?

3- On a windows xp machine do you use the same version of office and do not encounter this problem
4- On a windows xp machine do you use the same version of office Do you get the Document information panel pop up as you open the document ?

5- Does this happen to all libraries ?
6- Are you able to create a blank library with no version control and put a .txt file and a .docx file and attempt to open with browser do you see any difference ?

7- Goto the library in question  - > Settings -.> content types -  >List Content Type > Document Information Panel Settings
see if you have custom one and if you are forcing the DIP to open.


Thanks
0
 
bradoconnor75Author Commented:
I found that the excel file that the hyperlinks were pointing to had changed so it looks like setting excel to run in compatibility mode of xp SP3 does make it work, but I don't want to have to run my office programs in compatibility mode.

Do you still want all of the answers to your questions or does that change your questions?
0
 
GeorgeGerguesCommented:
These are not really questions it is more of tests you can create / debug on your own.

Is the file in question a xls or xlsx ?

that is something else.
0
 
bradoconnor75Author Commented:
It is an xls file. Everything also works if I give them edit rights to the library.

1. No the documents do not have required fields.
2. I don't think my version of Sharpoint has version control
3. Yes the XP system also has Office 2007
4. Yes it asks if I want to open the documant from the companyweb
5. Yes same problem in all libraries
6.  I can't put a xlsx or a docx file on my version. I only have this problem with Office files anything else opens fine.
0
 
GeorgeGerguesCommented:
I don't see that as a sharepoint specific issue .
I hope someone can figure this out.
0
 
omgangIT ManagerCommented:
bradocconor75, I don't have a solution for you but wanted to chime in and say I see the exact same behavior with Win 7 32-bit.  I have two machines side by side, one Win 7 the other Win XP.  Both have IE8.  The XP machine will open Office docs from a Sharepoint Site no problem.  On the Win 7 machine I receive the user credentials dialogue box.  If I click Cancel in the dialogue box the Office document still loads correctly.

I haven't really looked into it much since our enterprise environment is still officially Win XP and Win 7 is not supported, e.g. 'hello this is the help desk, how can I help you?  what's that?  your computer is on fire?  what operating system please?  oh, I'm sorry, Windows 7 is not a supported operating system......'

I'll ask around and see if anyone has figured out what is causing it and how to fix; there are quite a few, ahem, radicals around testing out Windows 7.
OM Gang
0
 
bradoconnor75Author Commented:
I agree I don't think Sharepoint is the problem. Thanks for the ideas!!
0
 
bradoconnor75Author Commented:
Thanks for checking even though it's not a supported OS. I knew it was going to easy upgrading from XP to 7.
0
 
omgangIT ManagerCommented:
Some progress on this.  Pretty sure it's IE8 or IE8/Win7 related.  After some config settings I am now able to view office documents from a Sharepoint site without receving the user credentials pop up box.......in FIREFOX!  Still can't figure out what is causing the prompt in IE8 but after performing the following in FF I can open docs immediately from Sharepoint sites:

   1. Open Firefox.
   2. Enter the following for the URL:  about:config
   3. When warned to be careful, click the “I’ll be careful, I promise” button.
   4. In the Filter field, enter this value:  network.automatic-ntlm-auth.trusted-uris
      Note: If the value is not there, you can add it as a new string.
   5. Right click on the value and choose Modify.
   6. Enter the following string:  Sharepoint.MyDomain.Com     <--- change for your sharepoint envrion
   7. Click Ok.
   8. You shouldn’t have to close and re-open Firefox but some people like to do this anyway.

I am hearing that this issue is not common in our envrionment (for users that have Win7) and that adding our Sharepoint environ as a trusted site in IE8 allows full functionality but it still doesn't work for me.

OM Gang
0
 
bradoconnor75Author Commented:
Thanks for the info. I had a busy Friday so I never got to try this. I will try it Monday and will let you know what I find.

Thanks again.
0
 
bradoconnor75Author Commented:
Sorry it took me so long to get back to this. I tried this and it does let me open the office file but I still get an error of "Cannot open the specified file" when I click on a hyperlinked office document in that file. This is the same thing I set the compatibilty to XP SP3 earlier. Still the only way it works crectly is giving edit rights to the documents which isn't an option. Any other ideas??
0
 
omgangIT ManagerCommented:
No unfortunately.  I've been working on trying to resolve the issue on my Win 7 machine and have had no luck.  I've tried setting sites/domain in my local intranet security zone; resetting IE8 to factory; clear all certificates in IE8, etc.  I've done the reg key add as described here http://support.microsoft.com/kb/943280/en-us.  Nothing has worked.  Not only am I prompted for user credentials, which are not necessary because cancelling still allows the doc to be opened, there is quite a bit of latency when attempting to retrieve the doc from the Sharepoint site......20-25 seconds or so.  The docs load within seconds on an XP machine.  Enterprise IT tech support here indicates they've seen this on other Win 7 installations but adding the appropriate sharepoint domain URL path (*.sharepoint.mydomain.com) to Trusted Sites in IE8 has resolved the issue.  Not for me....I must be lucky.
OM Gang
0
 
bradoconnor75Author Commented:
I must be really lucky since all of mine do this. I've tried that also but it shouldn't even matter with mine since my URL is http://companyweb for my sharepoint  so there is no period.
0
 
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.