SMTP question

I have an internal SMTP server that is on our domain. We do not own the public domain name of our internal domain name. So there are some mail servers that are listing it as spam. Normally we just have the computer name in the email message then the SMTP automatically adds our domain name to the end. For example I have server1 send a message but when it sends it states its from server1.domain.com. Is there a way on the SMTP server to spoof the name so that its coming from our domain name that we own publicly? Thanks. I hope that makes sense.
Thomas NSystems Analyst - Windows System AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jaustin1Commented:
You should be able to make your SMTP server use the correct domain name.  You'll probably need to provide what type of SMTP server you're using in order to get more explicit instructions.
0
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
Sorry I am using IIS version 6 on 2003 server. I can change the from name at the servers that are originally sending the message but its over 200 so it would be easier if I could just change something at the SMTP server.
0
jaustin1Commented:
You should be able to create a new virtual server in the IIS 6 mgmt console to test.  When you're created the smtp virtual server, you are presented with the Default Domain field, which is where you'd put the actual domain you want to send from.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
Thanks jaustin1...that sounds easy enough. Do I just create it then delete the current one? How does it know which one to use once we put in the server name or do I just put the full path of the new virtual server? Sorry I am very new to SMTP.
0
jaustin1Commented:
I would create the new one first.  It should default to stopped with a red X.  If you can risk a moment of downtime, you can stop the one that's already running (just right-click, stop) and then start the other one to test.  If it doesn't work, you can always stop the new one and start the old one up again.
0
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
I just changed the SMTP virtual server that I had to the domain name that I want to use and now it wont send even the messages that worked fine before. It goes directly into the "badmail" folder.I tried restarted it and still no good. All I did was change the domain name
0
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
what could be the problem?
0
jaustin1Commented:
Yeah, I don't think you want to change anything on the one you already had; you want to create a new one so that you can test before getting rid of the old one.  I also don't think you can change the default domain name of an SMTP Virtual Server that's already there; you can only add an alias or a receiving domain.  I would change the one you had back like it was, then create a separate one to test with.
0
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
Does it matter under the virtual server properties | delivery | advanced that the fully qualified name is different? I had to use the old domain name because the Check DNS button is that its valid.
0
jaustin1Commented:
Actually that's something else you could try:  You could use your existing Virtual Server and try entering the domain name you want in the Masquerade domain field.  Here's a little more info from the Help file:


Masquerade domain
The masquerade domain name replaces the local domain name listing in Mail From lines in the SMTP protocol.

Fully qualified domain name
Two records can be used to identify and verify a computer in a TCP/IP network:

The mail exchanger (MX) record


The address (A) record


The MX record identifies the host and domain name associated with the SMTP virtual server. The MX record uses the fully qualified domain name (FQDN) for the domain name. The A record identifies the IP address for the computer. When both records are used, name resolution occurs faster.

For Windows Server 2008 SMTP Server to process MX records, an FQDN must be designated. An FQDN is used by Domain Name System (DNS) to identify the host server for a domain. The syntax is host.domain. For example, CompanyA.com may have several host servers, with one named Server01. The FQDN for the server would be Server01.CompanyA.com.

By default, the FQDN is the name of the default domain configured for the SMTP virtual server. To override the automatic use of the default domain, change the FQDN on the Delivery tab.
0
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
I changed it back and added the new virtual server. Then I disable the old one. Now it doesnt send a message and it doesnt even go into the bad mail folder. Also just so you know I am using a vbs script to test out the mail send.
smtp.bmp
0
jaustin1Commented:
Hmm.  Make sure you've duplicated all other settings from the old virtual server to the new one.  Only the name and domain should be different.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas NSystems Analyst - Windows System AdministratorAuthor Commented:
I tried a different domain we had and it worked. Go figure. Thanks!
0
jaustin1Commented:
Excellent!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.