• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1484
  • Last Modified:

How do I get an HP Deskjet F4210 to work?

Hello

I brought to home my friend's printer (HP Deskjet F4210). I'm using Xubuntu 10.04.
When I use the command

lpr scanned.pdf

the printer does nothing. lpq writes

Deskjet-F300-series is not ready
Rank    Owner   Job     File(s)                         Total Size
1st     xralf 61      scanned.pdf                     1690624 bytes
2nd     xralf 62      (stdin)                         0 bytes
3rd     xralf 63      scanned.pdf                     1690624 bytes

I installed the driver according to this manual

Could you help me to figure out what is wrong?
0
xRalf
Asked:
xRalf
  • 11
  • 10
  • 6
3 Solutions
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Update your cups :

sudo apt-get install cupsys cupsys-client
0
 
xRalfAuthor Commented:
I updated cups but nothing changed.
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Run this command it will perform a check on your dependences, read the log and (apt-get install ****** packages)
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
xRalfAuthor Commented:
This command?

apt-get install ****** packages

Why so many stars?
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Sorry that was not clear, I meant once you find out the missing dependences, install them replacing the stars with the missing dependecy.

e.g apt-get install cups (if cups is missing) is it clear now?

0
 
xRalfAuthor Commented:
How can I find out which dependencies are missing?
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Try the following, I know it runs on Fedora I am not sure on Ubuntu:

hp-check -t
0
 
xRalfAuthor Commented:
hp-check -t ends with error message
error:  No system tray detected on this system.  Unable to start, exiting. 

Open in new window

0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
The driver install did not go well.

apt-get clean

apt-get update

Then re-install drivers again.
0
 
xRalfAuthor Commented:
I installed it again. It printed the test page.
but the problem described in the question remains.
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
Time to get a moderator to reffer the question to Geniuses or extra attention.
0
 
xRalfAuthor Commented:
OK, I will post it to the moderator. Thank you for your help.
0
 
farzanjCommented:
You should use the cups GUI

Open a web browser

Enter the address

http://localhost:631

You need to find your printer in the add a printer option

When you open the web browser, you would find the following heading on the page

CUPS for Administrators
|
----------->Adding Printers and Classes
                           |
                           ---->  Printers ----------> Add Printer  (Try this first, if you don't get success, go to find new printer option)
0
 
farzanjCommented:
Please try my solution above
0
 
xRalfAuthor Commented:
I tried the cups GUI,

I can print the test page, but the problem still remains.
0
 
farzanjCommented:
In the GUI, there is an option to make it ready.

If this is not the problem, please be more specific and show exact error messages, may be screen shots so that I can help you.
0
 
xRalfAuthor Commented:
I printed a test page.

In the GUI -> Printers it has Status "Idle - "ready to print"" so that should mean that it is ready.

But lpq shows
Deskjet-F300-series is not ready

F300 is my own disconnected printer. Why it doesn't show the F4210 printer?
0
 
farzanjCommented:
Try

enable <printerName>
0
 
farzanjCommented:
Do:
enable destination

or
cupsenable destination
0
 
farzanjCommented:
SO it should be,

enable Deskjet-F300-series

or

cupsenable Deskjet-F300-series
0
 
xRalfAuthor Commented:
I need to enable F4210 printer, with F300 connected there was no problem.
I don't know how to find out the name of cupsenable parameter.

I'm sending the output of
$ sudo lsusb -v -s 002 > printer_information
printer-information
0
 
farzanjCommented:
Please use one of these commands.  Please show me the output

Find all printers  
lpstat -p

Open in new window

All printers accepting jobs
 
lpstat -a

Open in new window


Your default printer
 
lpstat -d

Open in new window


 
0
 
farzanjCommented:
If it is just a matter of wrong default printer, you can easily make the printer of your choice default by issuing command

 
lpoptions -d <PRINTER_NAME>

Open in new window


Where the PRINTER_NAME should be obtained and available in both of the first two commands given above.  
0
 
xRalfAuthor Commented:
$ lpstat -p
printer Deskjet-F300-series disabled since Fri 25 Mar 2011 10:28:48 AM CET -
	Unplugged or turned off
printer Deskjet-F4200-series is idle.  enabled since Mon 04 Apr 2011 09:55:08 AM CEST
printer Deskjet_F4200 is idle.  enabled since Mon 04 Apr 2011 09:55:08 AM CEST
printer HP_Deskjet_F4200_series is idle.  enabled since Mon 04 Apr 2011 09:55:08 AM CEST

Open in new window


$ lpstat -a
Deskjet-F300-series accepting requests since Fri 25 Mar 2011 10:28:48 AM CET
Deskjet-F4200-series accepting requests since Mon 04 Apr 2011 09:55:08 AM CEST
Deskjet_F4200 accepting requests since Mon 04 Apr 2011 09:55:08 AM CEST
HP_Deskjet_F4200_series accepting requests since Mon 04 Apr 2011 09:55:08 AM CEST

Open in new window


$ lpstat -d
system default destination: Deskjet-F300-series

$ sudo lpoptions -d HP_Deskjet_F4200_series
auth-info-required=none copies=1 device-uri=hp:/usb/Deskjet_F4200_series?serial=CN8BD4G1XS05C3 finishings=3 job-hold-until=no-hold job-priority=50 job-sheets=none,none marker-change-time=0 media=na_letter_8.5x11in number-up=1 printer-commands=none printer-info='HP Deskjet F4200 series' printer-is-accepting-jobs=true printer-is-shared=false printer-location printer-make-and-model='HP Deskjet f4200 Series, hpcups 3.11.3a' printer-state=3 printer-state-change-time=1301903708 printer-state-reasons=none printer-type=2134028 printer-uri-supported=ipp://localhost:631/printers/HP_Deskjet_F4200_series

Open in new window


lpr scanned.pdf works now, but it prints very big text (approximately 20 times bigger).

0
 
farzanjCommented:
Keep your fingers crossed.  There is some good news at least.


There are three command that I would suggest you to try:
Please feel free to set try different values

Try scaling

 
lpr -o scaling=75 scanned.pdf

Open in new window


Character per inch
lpr -o cpi=10 scanned.pdf

Open in new window


Lines per inch

 
lpr -o lpi=8 scanned.pdf

Open in new window


Please let me know how it goes.  Unfortunately, you will have to play with these values /any combination of these yourself to determine the correct values--waste some paper :(

Once you are happy, you have to issue the command

sudo lpoptions -o cpi=<val> -o lpi=<val> -o scaling=<val> HP_Deskjet_F4200_series

Open in new window

0
 
farzanjCommented:
Sorry, the last command should be like
 
sudo lpoptions -o cpi=<val> -o lpi=<val> -o scaling=<val> -p HP_Deskjet_F4200_series

Open in new window


If you want to do it only for this printer, otherwise if you want to do these changes regardless of your printer, just  remove the -p <printer> part.
0
 
xRalfAuthor Commented:
Thank you
$ sudo lpoptions -o scaling=100 -p HP_Deskjet_F4200_series

Open in new window

works perfectly.

That's interesting that in F300 printer there is not needed to set scaling.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

  • 11
  • 10
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now