CAPTCHA and Word Verification images don't display in browser

We have 7 computers running XP SP3 and IE8.  5 of them will display word verification (i.e. Captcha) images perfectly very time.  Two will not show them at all, on a wide variety of sites that require them (nytimes.com, toktumi.com, etc.).  The two that don't have the same "Medium-High" security settings and 'Medium' privacy setting in IE8.  The Captcha box and instructions don't even display, so I wonder about something related to script execution, but that's just an uneducated guess.  Thanks in advance for any guidance.

Any idea
LVL 2
pseylerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

flubbsterCommented:
As a quick test, try running IE8 in no-addons mode:

To open Internet Explorer in no add-ons mode.
 
a. Click the Start button, click All Programs.
b. Click Accessories.
c. Click System Tools.
d. Then click Internet Explorer (No Add-ons)

test

If it works, go into Manage Add-ons and siable them all. Then begin to enable 1/2 at a time, zeroing in on the culprit. Once found, try re-installing the add-on.
0
pseylerAuthor Commented:
Good suggestion.  Tried it, though, and no improvement. Even with all add-ons disabled, the ReCaptcha container is not displayed.
0
flubbsterCommented:
Just in case, try it again following these complete steps please:

Click Start

·        Click All Programs

·        Click Accessories

·        Click System Tools

·        Click Internet Explorer (No add-ons) (this will open IE)

Once open, do the following:

·        Click Tools

·        Click Manage Add-ons

·        Click Toolbars and Extensions

·        Under Show: click All add-ons

·        Click any add-on

·        Press CTRL + A on your keyboard (this should select all add-ons)

·        Click Disable all

·        Click Close

·        Close Internet Explorer (No add-ons)

·        Open Internet Explore

test
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

pseylerAuthor Commented:
Tried it.  No difference.  Entire ReCaptcha container still not displayed.

For an example of a page containing the missing item:
     http://www.nytimes.com/mem/emailthis.html

Thanks for the attempt.
0
flubbsterCommented:
ok... now try using IE8 in Compatability mode. This will force the page to be displayed using IE7 protocol:

Open IE8

click on Tools menu, and select Compatibility View Settings.
 In the “Compatibility View Settings” dialog, tick the check box for Display all websites in Compatibility View option.
Click on Close button when done.

test
0
pseylerAuthor Commented:
Done.  Still no change.
0
flubbsterCommented:
Strange. Verify that "Show Pictures" is checked under Multimedia in Tools>Internet Options>Advanced tab.

If so, then it is most likely a security setting. Have you tried resetting it to factory defaults?

Do this from control panel with IE closed.

Control Panel
Internet Options
Advanced Tab
Reset advanced settings (do this first)
reset Internet Explorer to defaults (right below the reset advanced settings)

Open IE and test. Everything will be back to factory defaults, just as if you just installed it.
0
pseylerAuthor Commented:
Thanks for your persistence.  Tried it - no luck.  

In inspecting the source code for one of the non-functioing pages, it appears that the region that's not being displayed is controlled by a Java script.  Anyone got a sense of how to troubleshoot/debug the Java installation?
0
flubbsterCommented:
Is java scripting enabled? Specifically Active scripting?
0
flubbsterCommented:
You can download windows scripting, which includes jscript, separately:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=47809025-d896-482e-a0d6-524e7e844d81&DisplayLang=en
0
pseylerAuthor Commented:
Scripting is enabled.  MS Update installer you referenced above would not run because "Setup has detected that the Service Pack Version of this system is newer than the update you are applying.  There is no need to install this update."

This would suggest that the scripting components are already there, yes?
0
Danny ChildIT ManagerCommented:
Do all machines have the same version of java itself?
http://www.java.com/en/download/index.jsp

You may also want to clear the Internet Temp Files, then restart all browser sessions.  

And I take it that the PCs have been rebooted?  we get problems here with users and IE when they've been 1000's of hours since last reboot.... Sorry for stating the bleeding obvious.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flubbsterCommented:
Before installing the latest version of java, make sure you remove whatever is there first. Use control panel>add/remove programs

Select Java 2 runtime environment and remove it, then do as suggested above. Install the latest version.

version 6 Update 24
0
pseylerAuthor Commented:
No worries about the obvious.  All caches have been cleared and PC's reboted several times.  Problem has been going on for some weeks and we tried a couple of those paths first.
0
flubbsterCommented:
did you try updating java?
0
pseylerAuthor Commented:
I'm removing all the MANY old versions and updates - 2 left to uninstall
0
pseylerAuthor Commented:
The solution was indeed related to Java.  I removed ALL the old versions and rinstalled the current one.  IT now mostly works on both machines.  The Java installations appear to be a bit flaky (the java.com version tester doesn't always work) but we're getting the reCaptcha boxes 90% of the time now.  The real issue appears to be executing the code that causes the reCaptcha container to display when text is keyed  into the comment box.  Something keeps that code from being executed, which in turn keeps the reCaptcha hidden.  WIth the reinstall of the Java module it seems much (but not 100%) better.  Thanks all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
HTML

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.