Creation of Exchange 2010 mailbox database fails

I try to create an extra database on our Exch2010 server.

The command produces an error:
[PS] >new-mailboxdatabase -Server 'POSTIX' -Name 'High Volume Database' -EdbFilePath 'S:\Mailbox\High Volume Database\High Volume Database.edb' -LogFolderPath 'S:\Mailbox\High Volume Database'
Active Directory operation failed on ASTERIX.azo.lan. This error is not retriable. Additional information: Access is denied.
Active directory response: 00000005: SecErr: DSID-031521D0, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0
    + CategoryInfo          : NotSpecified: (0:Int32) [New-MailboxDatabase], ADOperationException
    + FullyQualifiedErrorId : D1A2D696,Microsoft.Exchange.Management.SystemConfigurationTasks.NewMailboxDatabase

- I'm running the command directly on our exch server (POSTIX)
- The user is the same user we used to install our server with (and this user is member of all possible admin groups :) ) (I could update schema and AD, so this user should have sufficient acces rights?)
- The path is the same as where our other database is installed.
- Asterix.azo.lan is our primary role DC.
- Trying the same from within the GUi also produces this error.
If I look in the gui: the DB name is visible, but has status "dismounted"
tdemeyerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
It seems you are member of Domain Admins, and Send As permission is denied for domain admin.

First try to run EMS Run As Administrator and try the same commond.
0
tdemeyerAuthor Commented:
no luck: same error
0
tdemeyerAuthor Commented:
Tried creating, but not mounting the DB. No problem. But when I try to mount this DB (even waited some time..) I stil get a similar error... (panoramix is one of our DC's):

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'test'.

test
Failed
Error:
Active Directory operation failed on panoramix.azo.lan. This error is not retriable. Additional information: Access is denied.
Active directory response: 00000005: SecErr: DSID-031521D0, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0


The user has insufficient access rights.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AmitIT ArchitectCommented:
Can you check this
http://support.microsoft.com/kb/977960

And run this command
Set-ADServerSettings –PreferredServer <DC FQDN>
0
tdemeyerAuthor Commented:
In fact, I already tested this, with no change (set preferred server to our 'primary role' DC). Same error message
0
tdemeyerAuthor Commented:
Just to be sure, I have created a new user. This user is member of following groups only : "Domain users" an "Organization Management".

Logged on... no luck.. same error when trying to mount a (freshly created) DB.
Active Directory operation failed on panoramix.azo.lan. This error is not retriable. Additional information: Access is denied.
Active directory response: 00000005: SecErr: DSID-031521D0, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0


The user has insufficient access rights.
0
tdemeyerAuthor Commented:
FOUND THE SOLUTION!!
Thanks to a simple -verbose switch, that produces not only a total differtent errormessage, but also pointed out the reason for the failure!! Had nothing to do with AD security!

[PS] C:\Windows\system32>Mount-Database "test" -Verbose
VERBOSE: [11:33:35.639 GMT] Mount-Database : Initializing Active Directory server settings for the remote Windows PowerShell session.
VERBOSE: [11:33:35.654 GMT] Mount-Database : Active Directory session settings for 'Mount-Database' are: View Entire Forest: 'False', Default Scope: 'azo.lan', Configuration Domain Controller: 'ASTERIX.azo.lan', Preferred Global Catalog: 'ASTERIX.azo.lan', Preferred Domain Controllers: '{ ASTERIX.azo.lan }'
VERBOSE: [11:33:35.654 GMT] Mount-Database : Runspace context: Executing user: azo.lan/Speciale Gebruikers/Serveraccounts/POSTIX, Executing user organization: , Current organization: , RBAC-enabled: Enabled.
VERBOSE: [11:33:35.670 GMT] Mount-Database : Beginning processing &
VERBOSE: [11:33:35.670 GMT] Mount-Database : Instantiating handler with index 0 for cmdlet extension agent "Admin Audit Log Agent".
VERBOSE: [11:33:35.951 GMT] Mount-Database : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient WriteScopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient Scope(s): {}, Exclusive Configuration Scope(s): {} }
VERBOSE: [11:33:35.951 GMT] Mount-Database : Searching objects "test" of type "Database" under the root "$null".
VERBOSE: [11:33:36.013 GMT] Mount-Database : Previous operation run on domain controller 'ASTERIX.azo.lan'.
VERBOSE: [11:33:36.013 GMT] Mount-Database : Processing object "test".
VERBOSE: [11:33:36.044 GMT] Mount-Database : Admin Audit Log: Entered Handler:Validate.
VERBOSE: [11:33:36.044 GMT] Mount-Database : Admin Audit Log: Entered ClassFactory:InitializeConfig.
VERBOSE: [11:33:36.044 GMT] Mount-Database : Admin Audit Log: Exited ClassFactory:InitializeConfig.
VERBOSE: [11:33:36.060 GMT] Mount-Database : Admin Audit Log: Exited Handler:Validate.VERBOSE: Mounting database "test".
VERBOSE: [11:33:36.075 GMT] Mount-Database : Resolved current organization: .
VERBOSE: [11:33:36.091 GMT] Mount-Database : Searching objects "azo.lan/Microsoft Exchange System Objects/SystemMailbox{ac2cdb50-7096-47d9-8e38-7ec3527423d4}" of type "ADRecipient" under the root "$null".
VERBOSE: [11:33:36.122 GMT] Mount-Database : Saving object "azo.lan/Microsoft Exchange System Objects/SystemMailbox{ac2cdb50-7096-47d9-8e38-7ec3527423d4}" of type "ADSystemMailbox" and state "New".
VERBOSE: [11:33:36.200 GMT] Mount-Database : Previous operation run on domain controller 'ASTERIX.azo.lan'.
VERBOSE: [11:33:36.341 GMT] Mount-Database : The remote call to pre-populate the cache was successful.
VERBOSE: [11:33:36.356 GMT] Mount-Database : Mounting database "test".
VERBOSE: [11:33:38.135 GMT] Mount-Database : Admin Audit Log: Entered Handler:OnComplete.
VERBOSE: [11:33:38.431 GMT] Mount-Database : Admin Audit Log: Exited Handler:OnComplete.
Couldn't mount the database that you specified. Specified database: test; Error code: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: An error occurred while preparing to mount database 'test'. Error: Could not find a part of the path 'C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\test'. [Database: test,Server: POSTIX.azo.lan].
    + CategoryInfo          : InvalidOperation: (test:ADObjectId) [Mount-Database], InvalidOperationException
    + FullyQualifiedErrorId : 10018,Microsoft.Exchange.Management.SystemConfigurationTasks.MountDatabase

VERBOSE: [11:33:38.852 GMT] Mount-Database : Ending processing &


Notice the "could not find a parth of the path" error.... So I opended my explorer and drilled down to ...\v14\mailbox. When opening .\mailbox I got a windows2008R2 notice "you need administrator permissions to open this folder" (or something similar).... Rather strange to get this error, as the default mailboxes where created in that folder without any problem at installation time.

So I decided to remove the DB through the EMC, and re-create it, but now entering a different path (in fact: I used the path where I moved the production DB's, on our SAN).

Mounted without any problem......

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tdemeyerAuthor Commented:
Found solution myself...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.