SMTP not working on Exchange 2010 (externally)

Hey guys,

My Exchange server 2010 install seems to be sending/receiving internally, but when I use a IMAP/POP configuration from an external location, my SMTP server doesn't seem to work.. When I do a Telnet it just says "Connection to host lost".

When I set it up on Outlook it shows the IMAP connects OK, just for SMTP says:

Send test e-mail message: Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).

Open in new window


Port 25 is open on the router, and it's running on Server 2008 R2 on a Hyper-V.

Also, when I try to add it as a "Microsoft Exchange" account, it can't find it.. I know I probably didn't set this up properly (as it's a fresh install and I'm new at Exchange).

Any help is appreciated.
barbs1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

adiloadiloCommented:
by default anonymous smtp access  is disabled on exchange 2010 , did you enable anonymous access on the receive connector ??

http://technet.microsoft.com/en-us/library/bb232021.aspx
0
koudryCommented:
Hello,

I don't know much about exchange 2010, so my view is you may have a network problem.  You might have already checked this, but if you have not, could try sending either standard or extended ping from the exchange 2010 to the router / gateway.  

The other thing you could check, is to see if there is Access Control List (ACL) on the router to which the exchange 2010 connects.  If there is an ACL, then make sure port 25 or SMTP is permitted.

Good luck.
0
koudryCommented:
Hello,

You did mention that port 25 is open, but you may want to check to be sure that you mail relay service properly configured and running on port 25.

Use CurrPorts  to check for running ports: http://www.nirsoft.net/utils/cports.html

There are also some materials that you MAY find useful:

How to allow the internal application servers to relay SMTP Messages thru Exchange Server 2010 and 2007 @ http://harun.se/blog/?p=114

Create an SMTP Receive Connector @ http://www.experts-exchange.com/expertsZone.jsp

You may also need to check the network administrator to be sure that SMTP or port 25 is allowed on the router to which the exchange server is connected.

Good luck

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.