Exchange 2010 Archive

I have just installed Exchange 2010 and am not very familiar with it yet. I created a seperate database for Archiving then enabled archiving on one of our mailboxes, pointing it to the Archive database. I set the archive policy to archive items over a year and it worked fine. When in OWA I could see the archive folder and all the items in it. I then tried to update the policy to archive items older than 6 months. I could see the change in the default policy but it was not updating on the mailbox. So I thought I would try to disable the archive then re-enable it. Still didn't work. Then I went to try it one more time and in my haste I disabled the mailbox, not the archive. No big deal, I went to Disconnected Mailbox and re-connected it. Then re-enabled the archive feature, pointing it to the archive database. Now when I look at the Archive in OWA it's empty. Is there a was for me to get into the Archive database and retreive these emails?
clifford_m71IT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkhaterCommented:
What you did is created a new archive to the user the old one is in still in the disconnected mailboxes
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
e_aravindCommented:
Outlook does not archive messages as expected based on the received date
http://support.microsoft.com/kb/295657
0
clifford_m71IT ManagerAuthor Commented:
Akhater,

I do see them there now. I say them because I enabled and disabled his archive a couple of times. So there are multiple disconnected archives. I guess I just had to be patient and wait for the AD replication to happen. Is there a way to force replication?
0
AkhaterCommented:
you mean a way to force them to show up in the disconnected mailbox the next time ?

clean-database MailboxDatabaseName
0
clifford_m71IT ManagerAuthor Commented:
Thanks for the help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.