Can't get IPhone or Droid to connect to server

I have a client using SBS 2003, I cant get my droid or an Iphone 3 to connect to the server and get email. I have no errors if I goto use exchange web I can connect. when I did https://server.com/oma I got the following message.


Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

I need to get this running today for my client. Please help
sdetraffAsked:
Who is Participating?
 
roylongConnect With a Mentor Commented:
If the server is using a specific version of Kerberos or SSL etc... Then the desktop clients may support the version but the iPhone may not... ...that was the direction I was going in.
0
 
vmaganCommented:
Make sure your directory is setup as an IIS application. In addition, make sure the ASP.NET worker process has been given the appropriate permissions.

take a look at this link:

http://geekswithblogs.net/ranganh/archive/2005/04/25/37613.aspx

0
 
sdetraffAuthor Commented:
Here is the strange part I can send out emails from my phone but still will not show any emails. It keeps trying and trying with no time outs.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
RovastarCommented:
Have al look in the iis logs for any http status codes when a the phones connect. Post the relevant entries here if you are unsure.
0
 
roylongCommented:
explain how you configured the email client to connect.  Sounds like a security / authentication issue.

Can you connect via imap?
0
 
vmaganCommented:
i dont  think it would be an authentication issue because they connect to server with no error message and they are able to send out emails.

does this happen to all phones or just those 2 phones?
0
 
vmaganCommented:
Oh your right good point.  

Did you set this up as an exchange on your phone?

What settings did you use?
0
 
sdetraffAuthor Commented:
Sorry I have not answered this I had been pulled off of it, I can connect to the OWA server, since the time of the question we even brought a new Go Daddy Cert rather then use a built in on. I have tried several different phones and still nothing, I can do Imap on my droid, yet I cant do it on a Iphone 3 or 4.

My main goal here was to get it to connect on the droid and Ipohones though exchange and not have to use IMAP. I have re installed SP2 to see if this made a difference and the outcome was no.

When i connect to the server using https://domain.com/oma that is where I was seeing the error.

One important note on the new SSL the customer brought is 2048 bit rather then the normal 1024.
0
 
sdetraffAuthor Commented:
Here is another test that was run:

ExRCA is testing Exchange ActiveSync.  
  The Exchange ActiveSync test failed.
   Test Steps
   Attempting to resolve the host name mail.igib.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 72.214.19.34
 
 Testing TCP port 443 on host mail.igib.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The certificate passed all validation requirements.
   Test Steps
   Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name mail.igib.com was found in the Certificate Subject Common name.
 
 Validating certificate trust for Windows Mobile devices.
  The test passed with some warnings encountered. Please expand the additional details.
   Additional Details
  The certificate is only trusted on Windows Mobile 5.0 with the Messaging and Security Feature Pack and later versions. Windows Mobile 5.0 devices won't be able to sync. Root = E=info@valicert.com, CN=http://www.valicert.com/, OU=ValiCert Class 2 Policy Validation Authority, O="ValiCert, Inc.", L=ValiCert Validation Network
 
 Testing the certificate date to confirm the certificate is valid.
  Date validation passed. The certificate hasn't expired.
   Additional Details
  The certificate is valid. NotBefore = 6/17/2011 10:19:58 PM, NotAfter = 6/17/2012 10:19:58 PM
 
 
 
 Checking the IIS configuration for client certificate authentication.
  Client certificate authentication wasn't detected.
   Additional Details
  Accept/Require Client Certificates isn't configured.
 
 Testing HTTP Authentication Methods for URL https://mail.igib.com/Microsoft-Server-Activesync/.
  The HTTP authentication methods are correct.
   Additional Details
  ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
 
 An ActiveSync session is being attempted with the server.
  Errors were encountered while testing the Exchange ActiveSync session.
   Test Steps
   Attempting to send the OPTIONS command to the server.
  The OPTIONS response was successfully received and is valid.
   Additional Details
  Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Wed, 22 Jun 2011 18:39:16 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

 
 
 Attempting the FolderSync command on the Exchange ActiveSync session.
  The test of the FolderSync command failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  Exchange ActiveSync returned an HTTP 500 response.
 
 
 
 
 
0
 
RovastarCommented:
If you are still get 500s I would go through this guide:
http://support.microsoft.com/kb/883380
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.