Virtual server can't connect

Afternoon guys. Been called into wrk after power shortage. Have two windows hpv 2008 boxes running 4 virtual machines each. Boxes have come back up but hyper1 which controls dom server lost it's nic address, subnet and default gateway. Reset to the correct address and configuration rebooted and seems ok. However I can't get access to any of the virtual servers. Ie dooms runs dhcp and dns. So when I log on to access the box remotely i can't access it. I have a feeling it's to do with the time difference??? What's the best why to resolve

Hyper1 : domain server dns dhcp
Hyper2 : back up domain server

Many thanks
LVL 1
dalewrightAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Svet PaperovIT ManagerCommented:
Try to ping your remote station from the servers by name. For the Remote Hyper-v manager to work, the server needs to be able to resolve dns name of the RSAT workstation.
0
dalewrightAuthor Commented:
That doesn't work because my client machine won't have an ip address as dhcp is on doms1 which is on the hyperv1. Ie Dom controller one isn't running as I can't start it. Does that make sense? I basically need to be able to start the server but I can't because i can't connect to the hyper v manager in windows 7. I have w feel the time is skewed and this is causing problems with ad authentication. Does this sound possible?? I can connect to hyper v 2 remotely through remote desktop but not through hyper manager again this doesn't allow me to start any of the clients such as the proxy server or Dom controller two. What would i need to sync the time? Ie net time or the win2008 comnand. Any help and advice is welcomed.
0
Svet PaperovIT ManagerCommented:
Can we go one question at a time, pls?

Do you have access to both servers – via RDP or on the console? If so you should be able to start the virtual machines from the hyper-v manager on the servers.

The command syntax is net time \\computername or /domain:domainname.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

dalewrightAuthor Commented:
Hi. Thanks for the post back

I can rdp into hyper2 but not hyper1. At the physical machine I can logon to the hyper v, hence having to reconfigure the adaptor settings after the power cut it was lost (the guy who set this up has done this once or twice before and he says it's to do with time skew and that it's a common problem in hyper v .... Personally I don't think it's been configured and installed correctly from
Day one).
0
dalewrightAuthor Commented:
When you say I should be able to start the virtual machines from the server I am only presented with a list of options from 1 to x, such as exit to command prompt etc
 I don't see anything that allows me to start any of the virtual servers.  I usually use hyper manager on my client machine through windows 7 to configure the machines. Thanks again
0
Svet PaperovIT ManagerCommented:
OK. I understand: you have Hyper-V Server on hyper-1 and Windows Server with Hyper-V on hyper-2. Is that correct? So, you don’t have GUI on hyper-v but you have a Windows GUI on hyper-2, right?

Obviously the setup is not quite right since you depend on a DHCP server in VM for your management station (that should manage the same Hyper-V server). You should set a fixed IP address on your management station. Then try to reconnect to hyper-1 from RSAT.  
0
dalewrightAuthor Commented:
Nope hyper v on both physical boxes:
Hyper1: domain controller, dns, file server
Hyper2: domain controller, exchange, proxy

Each have their own virtual servers.

Can access hyper2 via rdp but not hyper1. Came into work this morning to Check time on both boxes and they Are correct so don't think it's time skew problem. Can pI
0
dalewrightAuthor Commented:
From my understanding (and i am not an expert like you guys) with the domain controller set on hyper1 as a virtual server, obv it isnt running to accept requests... Is there a way from the command line to start the virtual server so that dhcp, dns and AD services are running? PS i already have a static IP address set on my workstation.

Many thanks
0
dalewrightAuthor Commented:
also tried looking into powershell to see if there is a command that  i can execute to start the Virtual Server.. However, everytime you enter anything, such as GET-VMSUMMARY, it cries about problems finding the objects.. I have a feeling this setup is all wrong and not very stable, however, i need to get it back up and running by the end of the day. :(
0
dalewrightAuthor Commented:
The reason for the commands not working is that you need to install a script in a temp directory and then issue commands. There must be a simple way to start the servers from the command line at least  "o/
0
salaskidCommented:
so
hyper1 is a server  real live box  and runs these VM's DC DNS DHCP FS  
hyper2 is a server  real live box   and runs these VM's DC EXCH PROXY
Correct?
hyper1 you can logon locally and RDP
hyper2 you can logon locally BUT NOT RDP
Correct?
on hyper1 check your Firewall settings and make sure it is set to ALLOW RDP connections!

also both of these machines should have STATIC ADDRESSES also all of these listed VM's should also be static.
0
dalewrightAuthor Commented:
hi salaskid.
No, nearly right...

Hyper1 can logon locally BUT CANT RDP (everything was fine until we had a power cut on saturday, could remotely manage all devices using hyper-v manager.

Hyper2 can RDP and logon on remotely.

Both have static IP addresses, however, i have been looking through some documentation which i was given for an handover, and i have note stating that HYPER one has two NIC's teamed and NOT static IP???? Strange and i have emailed the org guy to clarify but no answer.

Although i have a document with all IP addresses and hyper 1 def had a static IP, i am unable to check the adaptor settings as i just have the server core with the 15 options. No GUI interface to... Cant ping HyperV2 from HyperV1 but can ping other VLAN (we run two VLAN's) DC from Hyper2 with no problems. IPConfig/All displays all the correct information and configuration.

All VM's have static IP's

I honestly think this has been setup and configured with little thought and planning.. mess is springing to mind.

Cheers
0
salaskidCommented:
did you check firewall settings and RDP settings on hyper1
?

if hyper1 has 2 nics and were teamed and are not now   i really don't think it would be a problem that can't be over come as to them being DHCP clients is forsure not correct!!
0
salaskidCommented:
core install   sorry,  i just seen that
when you are the console of hyper1  you should be able to turn on and off the firewall and remote admin settings

try running this:   this will turn on remote administration
netsh firewall set service RemoteAdmin ENABLE
here is complete list of command from console
http://blogs.technet.com/b/robse/archive/2008/06/09/server-2008-core-commands.aspx

I totally dislike the core setup,  I tried it and it's not for me,  sorry i like a gui
my opinion  for the ammount of memory used   give me the GUI   :-)
memory is cheap!
0
dalewrightAuthor Commented:
I have checked firewall settings and RDP is enabled on hyper1. Again, no modifications have taken place and everything was fine until the power outage. When i rebooted hyper2, it came up no problem, with static address of xx.xx.xx.10 (vm's have a range from 11 - 20 on hyper2)

Hyper1 however is a different story. When booted, it came up fine, however i couldnt access it remotely. I remember the previous guy saying there was a bug with hyper-v???? and that the NIC would lose its settings. I checked the ip address and subnet and they had been changed. So i reset the IP back to the org ip, configured the subnet etc and rebooted. Came back and everything looked fine. Domain name was correct, RDP was enabled and so... HOWEVER, i still cant remote into the server, which isnt a problem as i can get to the console, BUT i cant connect using Hyper V to start the domain controller (i have no idea why anyone would want to set the DC as a virtual server, surely it would have been better on its own box and then virtualize the rest) hence no DNS, no DHCP and no LAN connection...

I can RDP into VLAN 300 network and all clients are connected perfectly.

There is something not right and i have done the generic testing etc but i am at the end knowledge... been looking for answers for 2 days. Cheers for the help mate
0
dalewrightAuthor Commented:
I agree about the GUI. I am not into the CLI stuff at all, but i as mentioned mate, its all abit of a mess.
0
dalewrightAuthor Commented:
salaskid... Should the firewall on hyper1 be enabled? we have our own network control and security on the dom controller, so would the firewall be needed on the server core? sorry if its a stupid question (from a programming and database background) Cheers mate
0
salaskidCommented:
i never use the windwos firewall, when behind a real hardware firewall
0
salaskidCommented:
is this a windows 2008 core install or a 2008R2 core install?
0
dalewrightAuthor Commented:
Tried running that command, all OK....But still cant access the server remotely... Noted that when i ran netstat nothing came back??? all blank :0/
0
dalewrightAuthor Commented:
Its a Windows 2008R2 core install.
0
dalewrightAuthor Commented:
however when i run the command on hyper2 i get back the right information, including TCP protocol, the correct IP address, the machine that is connection and the state... Something leads me to believe that there is a problem with the NIC configuration on hyper1
0
dalewrightAuthor Commented:
Sorry, mistake:
"""I have checked firewall settings and RDP is enabled on hyper1. Again, no modifications have taken place and everything was fine until the power outage. When i rebooted hyper2, it came up no problem, with static address of xx.xx.xx.20(vm's have a range from 20 - 30 on hyper2 and 10-19 on Hyper1)

0
salaskidCommented:
ok
on hyper1 tyr running sconfig  this will bring up a dos looking setup
from there you will be able to do more  
option:4 configure remote management
option:7 Remote desktop setting
option:8 network settings

these would be where I would be looking
i know nothing about a bug in hyper-v

I would disable FW
0
salaskidCommented:
0
dalewrightAuthor Commented:
Salaskid
That was the first thing that i did... Everything is show correct how it should be...

Just read a post : http://social.technet.microsoft.com/Forums/en-US/winservercore/thread/d4eb7da0-7428-4ec0-a4d7-d6a980b2855f/

about NIC's changing their address... If i could access the NIC's configuration, that would help to see what is going on... Also since there is two NIC's installed on the server, ipconfig/all should show both adaptors, but only getting one NIC address returned.

this is seriously starting to bug me, you network admins/engineers must have excellent patience.
0
salaskidCommented:
network admins/engineers
that is what I do

try that link for that tool i just posted   it will get you to the nics and you can view them, mod them or anything
0
dalewrightAuthor Commented:
Salaskid

Managed to get access to the NIC's through the del server config manager when booting the machine. The server shows 2 nic (broadcom NXII) as listed with NO configuration??? Should this be right? Ie it gives the option to set the IP settings for both, BUT with there being two NIC's in there, which one would get the IP address? There is a way to see how the NIC's are teamed, but i have been unable to find the resouce on the web..

Cheers for the link
0
salaskidCommented:
what dell server is this?
I wouldn't think you would set them through server manager during boot
it should be something configured in windows
0
dalewrightAuthor Commented:
PowerEdge T610 . Both Servers are the same and model.  I know i keep going back to the same point, but the guy who set it up org said there was a problem when setting the NIC with a static IP because of teamed NIC (unless he was unsure if he had set it up correctly himself) its strange that nothing is showing when i run NETSTAT from hyper1 but everything is great with hyper2.

Its a cat and mouse situation at the moment.... :(
0
Cris_IconomuCommented:
Hi dalewright,

From your GET-VSUMMARY error I can assume that the XMLs are corrupt and the VM management service can't find the virtual machines anymore. Hyper-V will try to start them automatically but fails as it can't "see" the objects. This happens because ONLY valid XMLs are loaded as objects.

1. Try using the local admin account to access the hyper-v HOST remotely, not a domain account.
2. Check if you have remote access to the computer management console (I assume you have modified the config to be able to restart services remotely and so on). If so, check if all the relevant services are running (VM management, etc). If not, make sure you change the config (use this: http://archive.msdn.microsoft.com/HVRemote ) so you can change settings and start/restart services remotely, from your workstation
3. Check if you have access to the admin share (or C$ share). If so, navigate to the folder where you placed the XMLs, check if the XMLs of the machines are not corrupt and if they are, attempt to repair (see this thread for details: http://www.experts-exchange.com/Microsoft/Applications/Virtual_Server/Hyper-V/Q_26866436.html?cid=1131#a35067992 )
Make sure you make backup copies of the xmls before starting.

It is highly recommended to avoid joining the hosts to the domain and also change configurations to allow full remote management, not only Hyper-V
If my assumtions are incorret please accept my apologies.

Cris
0
Cris_IconomuCommented:
Hi again,

I was writing the above and didn't get all your messages in time. Try the below:

1. do a power flush: remove power, press and hold power button for more than 40 sec, then start
2. after windows starts, issue a graceful shutdown from command prompt: shutdown /r /t 5
3. If this does not fix the NIC issue, try updating the BIOS and BMC (baseboard management controller) firmware
4. If none of the above works, call Dell - you might need a new motherboard...

This issue seems to be happening after a forceful shutdown (such as a power failure) - the BIOS comes back with no info on the NIC settings

Cris
0
dalewrightAuthor Commented:
Hi Cris
1. Tried to connect remotely using the admin account for the machine and get back error: Cant find hyper1. This might mean that hyper1 does not belong to network.

Guys.

Think i might have a solution. Spoken to the guy who set it up and he says that DC 1 DOES not have a static address because of a problem with with broadcom adapter teamed NIC's. DC 2, which is on hyper2, has a DHCP reservation for it.... Soooo, if i can get DC2 on HYPER2 started, that will start to accept requests... He recommends sync times (however all times are correct) but this is not possible if i cant get the Virtual DOM2 started... is there a way in server core to start the host?

Cheers
0
salaskidCommented:
one option would be move all VM's from hyper1 to hyper2
if you have no access to hyper1 other that at console then you will need a external HDD to do it
I think this is what I would do if it was a HAVE TO HAVE RUNNING NOW issue

when you copy the vhd to new server though you will have to set the static IP of the machine again after it boots,  bacause the MAC address will be different on the new VM you created.  

this might be the fastest solution to get you back up
0
dalewrightAuthor Commented:
Hi cris, see post above...
0
dalewrightAuthor Commented:
Sorry correction:
Guys.

Think i might have a solution.

Spoken to the guy who set it up and he says that HYPER1 DOES not have a static address because of a problem with the broadcom adapter teamed NIC's.

DC 2, which is on hyper2, has a DHCP reservation for it....

Soooo, if i can get DC2  on HYPER2 started, then it will to accept requests...

He recommends sync times (however all times are correct) but this is not possible if i cant get the Virtual DOM2 started... is there a way in server core to start the host?

Cheers
0
salaskidCommented:
man this sounds like a real cluster F#$K setup
can't find nyper1  mean just that, can't resolve name   try the IP Address
no DNS no resolve
0
dalewrightAuthor Commented:
Now you know what i am faced with!!!! I have spent two days trying to figure out whats going wrong...

Lets revist what i need to do:

1. Need to get HYPER2 up and running, which it is via RDC, BUT i cant connect via the host name or the IP address through Hypver-V manager, running on my local workstation as at the moment it is not connected to the domain.

2. Is there ANY way to start DC2 (virtual machine on HYPER 2) from a command prompt? That way, DHCP and DNS will starting working so that it can handle requests from nodes and issue HYPER 1 with address of .10 (through reserveration)

Pleaseeee someone tell me this is possible as i have a couple of hundred of people needing to connect to the network tomorrow :) (you have to laugh or i would just end up crying)

Thanks again guys for your excellent help and effort.
0
salaskidCommented:
can you ping any of the machines? by address not name!
hyper1 hyper2  or any of the virtual machines?

when the main server boots it should start all services including hyper-v service, and IF the VM's are set to start automatically then they will start up




0
dalewrightAuthor Commented:
Nope, cant ping any of the VM's from the HYPER2, which means that they havent started when the physical machine was booted up.... Obv he didnt set the VM's to start automatically when he set them up  "/
0
salaskidCommented:
what about hyper2 can you ping it by address?
how about hyper1?
0
Cris_IconomuCommented:
dalewright,

did you check if hyper1 and hyper2 have network connectivity?
i.e. can you ping another IP on the network FROM them?
sometimes we forget to check the basic things....
0
dalewrightAuthor Commented:
cant ping either from my machine as there is no network connectivty. Cant seem to find anything on google about starting a VM from the CLI... If MS have not included this as a core feature, the designers want shot
0
salaskidCommented:
her is a link that talks about administering Hyper-v from the command line
it shows how to start a VM  
hope this help

http://www.virtualizationadmin.com/articles-tutorials/microsoft-hyper-v-articles/storage-management/administer-microsoft-hyper-v-command-line-cli.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dalewrightAuthor Commented:
Cris
Yes, BUT not from Hyper1 because at the moment it hasnt got an IP address until DC 2 on HYPER2 comes back up. Thats the problem mate, its a cat and mouse scenario... I can ping other servers (running two VLANS) and nodes on the other VLAN from HYPER2. I just cant get it start the VM's so that the domain comes back up... I cant believe that anyone would want to put a domain controller onto a V-Server if this is the type of problems that it can cause.

Thanks for help again guys.
0
salaskidCommented:
if you can't ping them by address there is something wrong!!!
they should be set static  Correct? or atleast hyper2 is correct?   then you should be able to ping it

0
dalewrightAuthor Commented:
Salaskid, already looked at that previously mate, but was unsure if i should use it... i guess i could download it onto a USB and then load it from there... worth a go.
0
dalewrightAuthor Commented:
I can ping HYPER2 from the other VLAN and ping nodes from hyper2, so thats working.
I cant ping from my workstation as there is no network connection... I dont know how he has set this crap up but this is crazy. i have never worked in envo like this before,
0
salaskidCommented:
can ping HYPER2 from the other VLAN and ping nodes from hyper2, so thats working.
I cant ping from my workstation as there is no network connection.


did you try installing the RSAT on another maching that can  ping hyper2  ???
0
Cris_IconomuCommented:
Try this:

1. on hyper2, in command prompt issue net stop vmms
2. start notepad, go to the folder where the virtual machines xmls are and open one of the xml files
3. look for      
<host_startup>
        <action type="integer">2</action>
        <delay type="integer">0</delay>
</host_startup>
4. If <action type> is 1, change it to 2
5. issue net start vmms

check if the VM started.
0
salaskidCommented:
http://www.experts-exchange.com/Microsoft/Applications/Virtual_Server/Hyper-V/Q_24619220.html

How to start up a VM in Hyper-V when I cannot access the Hyper-V server from HV Management Console?
0
Patrick NunezCommented:
Hello Gentlemen- I am late to the game but hope I may be able to help a little.  In reading the string I do not see any mention of assigning stating IP addresses to the Hyper1 host or the management station.  If I missed this step I apologize.  If not, please assign the static IP's to the NIC's, starting with the NIC on the management system.

On a side note, as soon as you get this back online create a physical domain controller and move your network resources such as DHCP to it...but of course this is a future task.
0
Cris_IconomuCommented:
I believe we're facing two problems here, probably relatively independent to each other:

1. One of the hosts does not have an IP address due to setup with dynamic IP
2. Second host - the one that has network connectivity fails to start the VMs - probbaly due to wrong settings (although it is weird why someone would not set the option to start always...)

There are a few details we don't know:
- are the VMs on first host running? If yes, they might not have network connectivity due to NIC failure to get an IP - MSs virtual switch has a peculiar functionality
- is the second host reacheable and manageable remotely? If yes, what is the issue that stops dalewright from launching the VMs remotely using RSAT? (i.e. errors? credentials?)
0
Patrick NunezCommented:
Seems that it would be advisable to assign the same static ip that DHCP assigns to this Broadcom team.  The ip is reserved and will not be assigned to another device and therefore would not cause and ip conflict on the network.

On the 2nd host, are the Hyper-V services tied to an AD account or a local account?  Are the Hyper-V services starting or failing?  If they are failing what information is posted in the Event Log?

That is a great point, the VM's may be running but inaccessible due to the ip issue. What about assigning a static, at least temporarily.

Also, since there was a power outage is it possible the Broadcom NIC teaming broke creating 2 independent NICs?  And if they did break the DHCP reservation may be irrelevant since the MAC address in the DHCP scope may be different than that advertised by the Broadcom NIC's.

With regards to launching the VM's remotely with RSAT? dalewright needs to review the event logs on Hyper2 for hints of causes to the failure.
0
dalewrightAuthor Commented:
Hi Guys

Using salaskid post in regards to installing the config powershell app, i have done that and managed to det DC2, proxy and exchange up and running. I can now Remote connect into the proxy, but i cant rdp into DC2 or exchange.

I can ping the VM's but i have a feeling that DC2 is not issuing DHCP to Hyper1. I have spoken with the guy who set it up and he said that the address for hyper1 must be dynamic and then let DC2 assign the IP address of .10.

Progress is being made, but its still over complicated. I am now trying to RDC into doms2 to check that DHCP and DNS is running with AD. But its throwing back now authenticated.

This has been 22222 long days.  :(
0
dalewrightAuthor Commented:
Guys

I did actually assign a static IP for the hyper1, but it didnt make a difference... If i could get the domain controller back up on doms2, i am sure that hyper1 would resolve itself for the time being... This is one crazy setup.
0
dalewrightAuthor Commented:
Gents... some good news :)

Thanks for your help, esp that top guy salaskid for the info... I have the domain now back up and running... This is what i did:

Run the config tool on hyper2 and configured the VM's to get them started
Rebooted HyperV1 and changed the NIC to pick up from the DHCP
A reservation in doms2 has been added for HyperV1 to be set to .10 (not the smartest of ways and it def needs changed and sorted with regards to the teaming of the NICS)
Run the config tool on hyper1 and started the VM's
Rebooted Doms2 and now everything is back up and running

Thank you very very much for all of your hardwork and effort... Fantastic bunch of people.. i am off home for nice cold beer (well 6) and some well earned rest.
0
dalewrightAuthor Commented:
Fanastic help... top guys
0
salaskidCommented:
glad to hear you got it going  and won't have a bunch of bored and m people
0
salaskidCommented:
m = mad
0
Svet PaperovIT ManagerCommented:
Wow! Nice team work guys! I had to take out my girlfriend yesterday evening and I had missed all that! My iPhone kept popping out alerts about all posts but I wasn’t allowed to check them :-(

I love EE. I hope we saved your a… dalewright :-)
0
Cris_IconomuCommented:
yeah, good do hear all good dalewright!
make sure you make some changes to avoid this in the future!
and good luck!
0
dalewrightAuthor Commented:
Yea fantastic helP. I love ee ESP as I work on my own and don't have anyone to bounce ideas off. The setup is a bit stupid to be honest but at least I have learned a great deal frOm this experience. Thanks again guys
0
Patrick NunezCommented:
Congratulations dalewright.  Now a little rest and start looking at the task of redesigning the environment so this does not happen in the future,  Good Luck.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.